summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-09-24 17:52:05 -0400
committerAaron Bauman <bman@gentoo.org>2020-09-24 17:52:05 -0400
commite6f5240b85d9d3af2c3386ae35db837ab40378d9 (patch)
treea236d71d8ffd484ed5333d6454b91841cff9bba0 /dev-db
parentgames-rpg/deponia-tcj: New package (diff)
downloadgentoo-e6f5240b85d9d3af2c3386ae35db837ab40378d9.tar.gz
gentoo-e6f5240b85d9d3af2c3386ae35db837ab40378d9.tar.bz2
gentoo-e6f5240b85d9d3af2c3386ae35db837ab40378d9.zip
dev-db/libdbi: port to EAPI=7
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/libdbi/libdbi-0.9.0.ebuild24
1 files changed, 10 insertions, 14 deletions
diff --git a/dev-db/libdbi/libdbi-0.9.0.ebuild b/dev-db/libdbi/libdbi-0.9.0.ebuild
index b1fe05a9a1b5..f042010c2407 100644
--- a/dev-db/libdbi/libdbi-0.9.0.ebuild
+++ b/dev-db/libdbi/libdbi-0.9.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit eutils autotools ltprune multilib
+inherit autotools
DESCRIPTION="A database-independent abstraction layer in C"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -14,7 +14,7 @@ IUSE="doc static-libs"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
SLOT=0
-DOCS="AUTHORS ChangeLog README README.osx TODO"
+DOCS=( AUTHORS ChangeLog README README.osx TODO )
RDEPEND=""
DEPEND="${RDEPEND}
@@ -24,21 +24,17 @@ DEPEND="${RDEPEND}
"
PDEPEND=">=dev-db/libdbi-drivers-0.9.0" # On purpose, libdbi-drivers 0.8.4 does not exist
-src_unpack() {
- unpack ${A}
- chown -R portage:portage "${S}"
-}
-
src_prepare() {
- #epatch "${FILESDIR}"/${PN}-0.9.0-fix-ac-macro.patch
- #epatch "${FILESDIR}"/libdbi-0.8.1-pkg-config.patch
- #cp -f "${FILESDIR}"/dbi.pc.in "${S}"/dbi.pc.in
- epatch "${FILESDIR}"/libdbi-0.9.0-doc-build-fix.patch
+ eapply "${FILESDIR}"/libdbi-0.9.0-doc-build-fix.patch
- # configure.in has been changed
+ mv configure.in configure.ac || die
+
+ # configure.in/ac has been changed
eautoreconf
+
# should append CFLAGS, not replace them
sed -i.orig -e 's/^CFLAGS = /CFLAGS += /g' src/Makefile.in
+ eapply_user
}
src_configure() {
@@ -50,7 +46,7 @@ src_configure() {
src_install() {
default
- prune_libtool_files --all
+ find "${D}" -name '*.la' -delete || die "removing .la files failed"
# syslog-ng requires dbi.pc
insinto /usr/$(get_libdir)/pkgconfig/