summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-08-25 21:05:20 +0200
committerPacho Ramos <pacho@gentoo.org>2016-08-25 21:09:43 +0200
commitdd3f2b42cf2984911cadb9ab2a99c2b47f23b99a (patch)
treec5618049129222bd72259112ce9ee70e1f53b428 /dev-dotnet/libgdiplus
parentmedia-sound/pms: dropped old 0.42-r1 from the tree (diff)
downloadgentoo-dd3f2b42cf2984911cadb9ab2a99c2b47f23b99a.tar.gz
gentoo-dd3f2b42cf2984911cadb9ab2a99c2b47f23b99a.tar.bz2
gentoo-dd3f2b42cf2984911cadb9ab2a99c2b47f23b99a.zip
dev-dotnet/libgdiplus: Drop old
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-dotnet/libgdiplus')
-rw-r--r--dev-dotnet/libgdiplus/Manifest1
-rw-r--r--dev-dotnet/libgdiplus/files/libgdiplus-3.12-giflib-quantizebuffer.patch298
-rw-r--r--dev-dotnet/libgdiplus/files/libgdiplus-3.12-underlinking.patch17
-rw-r--r--dev-dotnet/libgdiplus/libgdiplus-2.10.9.ebuild48
-rw-r--r--dev-dotnet/libgdiplus/libgdiplus-3.12.ebuild66
-rw-r--r--dev-dotnet/libgdiplus/libgdiplus-4.2-r1.ebuild51
6 files changed, 0 insertions, 481 deletions
diff --git a/dev-dotnet/libgdiplus/Manifest b/dev-dotnet/libgdiplus/Manifest
index eac96a494975..b0ac70f6d912 100644
--- a/dev-dotnet/libgdiplus/Manifest
+++ b/dev-dotnet/libgdiplus/Manifest
@@ -1,3 +1,2 @@
DIST libgdiplus-2.10.9.tar.bz2 2074317 SHA256 6ddeb6c327bada7cb6e06d1a20714f526a0c69520dfd42c12ddd032c3c5d964e SHA512 7f1944795c7ede5fd92a6d7e8d7d6cf2ef3c154e656b83e769b417f8f7195dd975084afe3c3cd1dda1ecb2c1167f76c0b5714cd16d549ff056add09763c6b26c WHIRLPOOL 0930cb2ad191c34b7ebd073f687536663bcfe9a44ed3296cf81bc9d43cfc7ee39d8f60f9b9f83f89847164b7366e514ee945737be50b82257209507c3b6e9c5d
-DIST libgdiplus-3.12.tar.gz 688120 SHA256 e61c4dc1bc2ba993e4f79029472efcf5760eb9e60eb20d9cd31f0ebe9113bfc9 SHA512 12c58e7ad99e5aa7caf19f64f47bddd399648292f3c2b9ade64e9051b0495bb8772af8ca9cdb6cb664d20c845d7136f028e10e659548bffd35e7604548bb8743 WHIRLPOOL 288ea9f2b8f5599278f039be1af32f54d0496da6ce70c3e937485d0a3a40494680a7c0fc55430602c256c487df1d57c0b6d8f6220a52b8ac0d7a48e6211d6ead
DIST libgdiplus-4.2.tar.gz 687398 SHA256 f332b9b8b44fd1c50b8d8d01a7296360b806c790b8297614739b3de1edbadfeb SHA512 102d1e07a106fa32640a20c4843bf82b3f628c5b7a3813d39c7712f2cd09d80dc5adb337a8d5bdbae065f876a0c433a5d8fcb7d761dff5ee08c48cac2cd2344e WHIRLPOOL a2580f026ec7d767ca038fa4e41c94a5613b69581c836b144c29b5cf1d97895d9c1c17b077caef760ceae65d35e809a7ef9b6c9089c43c0ec5be1d2bcc453ee0
diff --git a/dev-dotnet/libgdiplus/files/libgdiplus-3.12-giflib-quantizebuffer.patch b/dev-dotnet/libgdiplus/files/libgdiplus-3.12-giflib-quantizebuffer.patch
deleted file mode 100644
index 5d0b9c227e1a..000000000000
--- a/dev-dotnet/libgdiplus/files/libgdiplus-3.12-giflib-quantizebuffer.patch
+++ /dev/null
@@ -1,298 +0,0 @@
-diff --git a/src/gifcodec.c b/src/gifcodec.c
-index e1a0697..e645c6e 100644
---- a/src/gifcodec.c
-+++ b/src/gifcodec.c
-@@ -39,6 +39,293 @@ GUID gdip_gif_image_format_guid = {0xb96b3cb0U, 0x0728U, 0x11d3U, {0x9d, 0x7b, 0
-
- #include "gifcodec.h"
-
-+#define COLOR_ARRAY_SIZE 32768
-+#define BITS_PER_PRIM_COLOR 5
-+#define MAX_PRIM_COLOR 0x1f
-+
-+static int SortRGBAxis;
-+
-+typedef struct QuantizedColorType {
-+ GifByteType RGB[3];
-+ GifByteType NewColorIndex;
-+ long Count;
-+ struct QuantizedColorType *Pnext;
-+} QuantizedColorType;
-+
-+typedef struct NewColorMapType {
-+ GifByteType RGBMin[3], RGBWidth[3];
-+ unsigned int NumEntries; /* # of QuantizedColorType in linked list below */
-+ unsigned long Count; /* Total number of pixels in all the entries */
-+ QuantizedColorType *QuantizedColors;
-+} NewColorMapType;
-+
-+
-+/****************************************************************************
-+ * Routine called by qsort to compare two entries.
-+ ****************************************************************************/
-+static int
-+SortCmpRtn(const void *Entry1,
-+ const void *Entry2) {
-+
-+ return (*((QuantizedColorType **) Entry1))->RGB[SortRGBAxis] -
-+ (*((QuantizedColorType **) Entry2))->RGB[SortRGBAxis];
-+}
-+
-+/******************************************************************************
-+ * Routine to subdivide the RGB space recursively using median cut in each
-+ * axes alternatingly until ColorMapSize different cubes exists.
-+ * The biggest cube in one dimension is subdivide unless it has only one entry.
-+ * Returns GIF_ERROR if failed, otherwise GIF_OK.
-+ ******************************************************************************/
-+static int
-+SubdivColorMap(NewColorMapType * NewColorSubdiv,
-+ unsigned int ColorMapSize,
-+ unsigned int *NewColorMapSize) {
-+
-+ int MaxSize;
-+ unsigned int i, j, Index = 0, NumEntries, MinColor, MaxColor;
-+ long Sum, Count;
-+ QuantizedColorType *QuantizedColor, **SortArray;
-+
-+ while (ColorMapSize > *NewColorMapSize) {
-+ /* Find candidate for subdivision: */
-+ MaxSize = -1;
-+ for (i = 0; i < *NewColorMapSize; i++) {
-+ for (j = 0; j < 3; j++) {
-+ if ((((int)NewColorSubdiv[i].RGBWidth[j]) > MaxSize) &&
-+ (NewColorSubdiv[i].NumEntries > 1)) {
-+ MaxSize = NewColorSubdiv[i].RGBWidth[j];
-+ Index = i;
-+ SortRGBAxis = j;
-+ }
-+ }
-+ }
-+
-+ if (MaxSize == -1)
-+ return GIF_OK;
-+
-+ /* Split the entry Index into two along the axis SortRGBAxis: */
-+
-+ /* Sort all elements in that entry along the given axis and split at
-+ * the median. */
-+ SortArray = (QuantizedColorType **)malloc(
-+ sizeof(QuantizedColorType *) *
-+ NewColorSubdiv[Index].NumEntries);
-+ if (SortArray == NULL)
-+ return GIF_ERROR;
-+ for (j = 0, QuantizedColor = NewColorSubdiv[Index].QuantizedColors;
-+ j < NewColorSubdiv[Index].NumEntries && QuantizedColor != NULL;
-+ j++, QuantizedColor = QuantizedColor->Pnext)
-+ SortArray[j] = QuantizedColor;
-+
-+ qsort(SortArray, NewColorSubdiv[Index].NumEntries,
-+ sizeof(QuantizedColorType *), SortCmpRtn);
-+
-+ /* Relink the sorted list into one: */
-+ for (j = 0; j < NewColorSubdiv[Index].NumEntries - 1; j++)
-+ SortArray[j]->Pnext = SortArray[j + 1];
-+ SortArray[NewColorSubdiv[Index].NumEntries - 1]->Pnext = NULL;
-+ NewColorSubdiv[Index].QuantizedColors = QuantizedColor = SortArray[0];
-+ free((char *)SortArray);
-+
-+ /* Now simply add the Counts until we have half of the Count: */
-+ Sum = NewColorSubdiv[Index].Count / 2 - QuantizedColor->Count;
-+ NumEntries = 1;
-+ Count = QuantizedColor->Count;
-+ while (QuantizedColor->Pnext != NULL &&
-+ (Sum -= QuantizedColor->Pnext->Count) >= 0 &&
-+ QuantizedColor->Pnext->Pnext != NULL) {
-+ QuantizedColor = QuantizedColor->Pnext;
-+ NumEntries++;
-+ Count += QuantizedColor->Count;
-+ }
-+ /* Save the values of the last color of the first half, and first
-+ * of the second half so we can update the Bounding Boxes later.
-+ * Also as the colors are quantized and the BBoxes are full 0..255,
-+ * they need to be rescaled.
-+ */
-+ MaxColor = QuantizedColor->RGB[SortRGBAxis]; /* Max. of first half */
-+ /* coverity[var_deref_op] */
-+ MinColor = QuantizedColor->Pnext->RGB[SortRGBAxis]; /* of second */
-+ MaxColor <<= (8 - BITS_PER_PRIM_COLOR);
-+ MinColor <<= (8 - BITS_PER_PRIM_COLOR);
-+
-+ /* Partition right here: */
-+ NewColorSubdiv[*NewColorMapSize].QuantizedColors =
-+ QuantizedColor->Pnext;
-+ QuantizedColor->Pnext = NULL;
-+ NewColorSubdiv[*NewColorMapSize].Count = Count;
-+ NewColorSubdiv[Index].Count -= Count;
-+ NewColorSubdiv[*NewColorMapSize].NumEntries =
-+ NewColorSubdiv[Index].NumEntries - NumEntries;
-+ NewColorSubdiv[Index].NumEntries = NumEntries;
-+ for (j = 0; j < 3; j++) {
-+ NewColorSubdiv[*NewColorMapSize].RGBMin[j] =
-+ NewColorSubdiv[Index].RGBMin[j];
-+ NewColorSubdiv[*NewColorMapSize].RGBWidth[j] =
-+ NewColorSubdiv[Index].RGBWidth[j];
-+ }
-+ NewColorSubdiv[*NewColorMapSize].RGBWidth[SortRGBAxis] =
-+ NewColorSubdiv[*NewColorMapSize].RGBMin[SortRGBAxis] +
-+ NewColorSubdiv[*NewColorMapSize].RGBWidth[SortRGBAxis] - MinColor;
-+ NewColorSubdiv[*NewColorMapSize].RGBMin[SortRGBAxis] = MinColor;
-+
-+ NewColorSubdiv[Index].RGBWidth[SortRGBAxis] =
-+ MaxColor - NewColorSubdiv[Index].RGBMin[SortRGBAxis];
-+
-+ (*NewColorMapSize)++;
-+ }
-+
-+ return GIF_OK;
-+}
-+
-+/******************************************************************************
-+ * Quantize high resolution image into lower one. Input image consists of a
-+ * 2D array for each of the RGB colors with size Width by Height. There is no
-+ * Color map for the input. Output is a quantized image with 2D array of
-+ * indexes into the output color map.
-+ * Note input image can be 24 bits at the most (8 for red/green/blue) and
-+ * the output has 256 colors at the most (256 entries in the color map.).
-+ * ColorMapSize specifies size of color map up to 256 and will be updated to
-+ * real size before returning.
-+ * Also non of the parameter are allocated by this routine.
-+ * This function returns GIF_OK if succesfull, GIF_ERROR otherwise.
-+ ******************************************************************************/
-+static int
-+QuantizeBuffer(unsigned int Width,
-+ unsigned int Height,
-+ int *ColorMapSize,
-+ GifByteType * RedInput,
-+ GifByteType * GreenInput,
-+ GifByteType * BlueInput,
-+ GifByteType * OutputBuffer,
-+ GifColorType * OutputColorMap) {
-+
-+ unsigned int Index, NumOfEntries;
-+ int i, j, MaxRGBError[3];
-+ unsigned int NewColorMapSize;
-+ long Red, Green, Blue;
-+ NewColorMapType NewColorSubdiv[256];
-+ QuantizedColorType *ColorArrayEntries, *QuantizedColor;
-+
-+ ColorArrayEntries = (QuantizedColorType *)malloc(
-+ sizeof(QuantizedColorType) * COLOR_ARRAY_SIZE);
-+ if (ColorArrayEntries == NULL) {
-+ return GIF_ERROR;
-+ }
-+
-+ for (i = 0; i < COLOR_ARRAY_SIZE; i++) {
-+ ColorArrayEntries[i].RGB[0] = i >> (2 * BITS_PER_PRIM_COLOR);
-+ ColorArrayEntries[i].RGB[1] = (i >> BITS_PER_PRIM_COLOR) &
-+ MAX_PRIM_COLOR;
-+ ColorArrayEntries[i].RGB[2] = i & MAX_PRIM_COLOR;
-+ ColorArrayEntries[i].Count = 0;
-+ }
-+
-+ /* Sample the colors and their distribution: */
-+ for (i = 0; i < (int)(Width * Height); i++) {
-+ Index = ((RedInput[i] >> (8 - BITS_PER_PRIM_COLOR)) <<
-+ (2 * BITS_PER_PRIM_COLOR)) +
-+ ((GreenInput[i] >> (8 - BITS_PER_PRIM_COLOR)) <<
-+ BITS_PER_PRIM_COLOR) +
-+ (BlueInput[i] >> (8 - BITS_PER_PRIM_COLOR));
-+ ColorArrayEntries[Index].Count++;
-+ }
-+
-+ /* Put all the colors in the first entry of the color map, and call the
-+ * recursive subdivision process. */
-+ for (i = 0; i < 256; i++) {
-+ NewColorSubdiv[i].QuantizedColors = NULL;
-+ NewColorSubdiv[i].Count = NewColorSubdiv[i].NumEntries = 0;
-+ for (j = 0; j < 3; j++) {
-+ NewColorSubdiv[i].RGBMin[j] = 0;
-+ NewColorSubdiv[i].RGBWidth[j] = 255;
-+ }
-+ }
-+
-+ /* Find the non empty entries in the color table and chain them: */
-+ for (i = 0; i < COLOR_ARRAY_SIZE; i++)
-+ if (ColorArrayEntries[i].Count > 0)
-+ break;
-+ QuantizedColor = NewColorSubdiv[0].QuantizedColors = &ColorArrayEntries[i];
-+ NumOfEntries = 1;
-+ while (++i < COLOR_ARRAY_SIZE)
-+ if (ColorArrayEntries[i].Count > 0) {
-+ QuantizedColor->Pnext = &ColorArrayEntries[i];
-+ QuantizedColor = &ColorArrayEntries[i];
-+ NumOfEntries++;
-+ }
-+ QuantizedColor->Pnext = NULL;
-+
-+ NewColorSubdiv[0].NumEntries = NumOfEntries; /* Different sampled colors */
-+ NewColorSubdiv[0].Count = ((long)Width) * Height; /* Pixels */
-+ NewColorMapSize = 1;
-+ if (SubdivColorMap(NewColorSubdiv, *ColorMapSize, &NewColorMapSize) !=
-+ GIF_OK) {
-+ free((char *)ColorArrayEntries);
-+ return GIF_ERROR;
-+ }
-+ if (NewColorMapSize < *ColorMapSize) {
-+ /* And clear rest of color map: */
-+ for (i = NewColorMapSize; i < *ColorMapSize; i++)
-+ OutputColorMap[i].Red = OutputColorMap[i].Green =
-+ OutputColorMap[i].Blue = 0;
-+ }
-+
-+ /* Average the colors in each entry to be the color to be used in the
-+ * output color map, and plug it into the output color map itself. */
-+ for (i = 0; i < NewColorMapSize; i++) {
-+ if ((j = NewColorSubdiv[i].NumEntries) > 0) {
-+ QuantizedColor = NewColorSubdiv[i].QuantizedColors;
-+ Red = Green = Blue = 0;
-+ while (QuantizedColor) {
-+ QuantizedColor->NewColorIndex = i;
-+ Red += QuantizedColor->RGB[0];
-+ Green += QuantizedColor->RGB[1];
-+ Blue += QuantizedColor->RGB[2];
-+ QuantizedColor = QuantizedColor->Pnext;
-+ }
-+ OutputColorMap[i].Red = (Red << (8 - BITS_PER_PRIM_COLOR)) / j;
-+ OutputColorMap[i].Green = (Green << (8 - BITS_PER_PRIM_COLOR)) / j;
-+ OutputColorMap[i].Blue = (Blue << (8 - BITS_PER_PRIM_COLOR)) / j;
-+ } else
-+ fprintf(stderr,
-+ "\n%s: Null entry in quantized color map - that's weird.\n",
-+ "libgdiplus");
-+ }
-+
-+ /* Finally scan the input buffer again and put the mapped index in the
-+ * output buffer. */
-+ MaxRGBError[0] = MaxRGBError[1] = MaxRGBError[2] = 0;
-+ for (i = 0; i < (int)(Width * Height); i++) {
-+ Index = ((RedInput[i] >> (8 - BITS_PER_PRIM_COLOR)) <<
-+ (2 * BITS_PER_PRIM_COLOR)) +
-+ ((GreenInput[i] >> (8 - BITS_PER_PRIM_COLOR)) <<
-+ BITS_PER_PRIM_COLOR) +
-+ (BlueInput[i] >> (8 - BITS_PER_PRIM_COLOR));
-+ Index = ColorArrayEntries[Index].NewColorIndex;
-+ OutputBuffer[i] = Index;
-+ if (MaxRGBError[0] < ABS(OutputColorMap[Index].Red - RedInput[i]))
-+ MaxRGBError[0] = ABS(OutputColorMap[Index].Red - RedInput[i]);
-+ if (MaxRGBError[1] < ABS(OutputColorMap[Index].Green - GreenInput[i]))
-+ MaxRGBError[1] = ABS(OutputColorMap[Index].Green - GreenInput[i]);
-+ if (MaxRGBError[2] < ABS(OutputColorMap[Index].Blue - BlueInput[i]))
-+ MaxRGBError[2] = ABS(OutputColorMap[Index].Blue - BlueInput[i]);
-+ }
-+
-+#ifdef DEBUG
-+ fprintf(stderr,
-+ "Quantization L(0) errors: Red = %d, Green = %d, Blue = %d.\n",
-+ MaxRGBError[0], MaxRGBError[1], MaxRGBError[2]);
-+#endif /* DEBUG */
-+
-+ free((char *)ColorArrayEntries);
-+
-+ *ColorMapSize = NewColorMapSize;
-+
-+ return GIF_OK;
-+}
-+
- #ifdef EgifOpen
- /* giflib declares this incorrectly as EgifOpen */
- extern GifFileType *EGifOpen(void *userData, OutputFunc writeFunc);
diff --git a/dev-dotnet/libgdiplus/files/libgdiplus-3.12-underlinking.patch b/dev-dotnet/libgdiplus/files/libgdiplus-3.12-underlinking.patch
deleted file mode 100644
index 164f99431cbd..000000000000
--- a/dev-dotnet/libgdiplus/files/libgdiplus-3.12-underlinking.patch
+++ /dev/null
@@ -1,17 +0,0 @@
- tests/Makefile.am | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/tests/Makefile.am b/tests/Makefile.am
-index fb7aa7e..4d752e1 100644
---- a/tests/Makefile.am
-+++ b/tests/Makefile.am
-@@ -13,7 +13,8 @@ DEPS = \
-
-
- LDADDS = \
-- $(top_builddir)/src/libgdiplus.la
-+ $(top_builddir)/src/libgdiplus.la \
-+ -lm
-
- noinst_PROGRAMS = \
- testgdi testbits testclip testreversepath
diff --git a/dev-dotnet/libgdiplus/libgdiplus-2.10.9.ebuild b/dev-dotnet/libgdiplus/libgdiplus-2.10.9.ebuild
deleted file mode 100644
index fe947ef804e4..000000000000
--- a/dev-dotnet/libgdiplus/libgdiplus-2.10.9.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=2
-
-inherit eutils go-mono mono flag-o-matic
-
-DESCRIPTION="Library for using System.Drawing with mono"
-HOMEPAGE="http://www.mono-project.com"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="cairo"
-
-RDEPEND=">=dev-libs/glib-2.16:2
- >=media-libs/freetype-2.3.7
- >=media-libs/fontconfig-2.6
- >=media-libs/libpng-1.4:0
- x11-libs/libXrender
- x11-libs/libX11
- x11-libs/libXt
- >=x11-libs/cairo-1.8.4[X]
- media-libs/libexif
- >=media-libs/giflib-4.1.3
- virtual/jpeg:0
- media-libs/tiff:0
- !cairo? ( >=x11-libs/pango-1.20 )"
-DEPEND="${RDEPEND}"
-
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/${P}-gold.patch"
- "${FILESDIR}/${PN}-2.10.1-libpng15.patch" )
-
-src_prepare() {
- go-mono_src_prepare
- sed -i -e 's:ungif:gif:g' configure || die
-}
-
-src_configure() {
- append-flags -fno-strict-aliasing
- go-mono_src_configure --with-cairo=system \
- $(use !cairo && printf %s --with-pango) \
- || die "configure failed"
-}
diff --git a/dev-dotnet/libgdiplus/libgdiplus-3.12.ebuild b/dev-dotnet/libgdiplus/libgdiplus-3.12.ebuild
deleted file mode 100644
index 96eb910ef869..000000000000
--- a/dev-dotnet/libgdiplus/libgdiplus-3.12.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit autotools eutils dotnet flag-o-matic
-
-DESCRIPTION="Library for using System.Drawing with mono"
-HOMEPAGE="http://www.mono-project.com"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-SRC_URI="http://download.mono-project.com/sources/${PN}/${P}.tar.gz"
-
-IUSE="cairo"
-
-RDEPEND=">=dev-libs/glib-2.2.3:2
- >=media-libs/freetype-2.3.7
- >=media-libs/fontconfig-2.6
- >=media-libs/libpng-1.4:0
- x11-libs/libXrender
- x11-libs/libX11
- x11-libs/libXt
- >=x11-libs/cairo-1.8.4[X]
- media-libs/libexif
- >=media-libs/giflib-4.2.3
- virtual/jpeg:0
- media-libs/tiff:0
- !cairo? ( >=x11-libs/pango-1.20 )"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- "${FILESDIR}/${P}-giflib-quantizebuffer.patch"
- "${FILESDIR}/${P}-underlinking.patch"
- )
-
-RESTRICT="test"
-
-src_prepare() {
- epatch "${PATCHES[@]}"
- sed -i -e 's:ungif:gif:g' configure.ac || die
- append-flags -fno-strict-aliasing
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-dependency-tracking \
- --disable-static \
- $(usex cairo "" "--with-pango")
-}
-
-src_install () {
- MAKEOPTS+=" -j1"
- default
-
- dotnet_multilib_comply
- local commondoc=( AUTHORS ChangeLog README TODO )
- for docfile in "${commondoc[@]}"; do
- [[ -e "${docfile}" ]] && dodoc "${docfile}"
- done
- [[ "${DOCS[@]}" ]] && dodoc "${DOCS[@]}"
- prune_libtool_files
-}
diff --git a/dev-dotnet/libgdiplus/libgdiplus-4.2-r1.ebuild b/dev-dotnet/libgdiplus/libgdiplus-4.2-r1.ebuild
deleted file mode 100644
index 2265860639cd..000000000000
--- a/dev-dotnet/libgdiplus/libgdiplus-4.2-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils dotnet
-
-DESCRIPTION="Library for using System.Drawing with mono"
-HOMEPAGE="http://www.mono-project.com"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-SRC_URI="http://download.mono-project.com/sources/${PN}/${P}.tar.gz"
-
-IUSE="cairo"
-
-RDEPEND=">=dev-libs/glib-2.2.3:2
- >=media-libs/freetype-2.3.7
- >=media-libs/fontconfig-2.6
- >=media-libs/libpng-1.4:0
- x11-libs/libXrender
- x11-libs/libX11
- x11-libs/libXt
- >=x11-libs/cairo-1.8.4[X]
- media-libs/libexif
- >=media-libs/giflib-4.2.3
- virtual/jpeg:0
- media-libs/tiff:0
- !cairo? ( >=x11-libs/pango-1.20 )"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- econf \
- --disable-dependency-tracking \
- --disable-static \
- $(usex cairo "" "--with-pango")
-}
-
-src_install () {
- default
-
- dotnet_multilib_comply
- local commondoc=( AUTHORS ChangeLog README TODO )
- for docfile in "${commondoc[@]}"; do
- [[ -e "${docfile}" ]] && dodoc "${docfile}"
- done
- [[ "${DOCS[@]}" ]] && dodoc "${DOCS[@]}"
- prune_libtool_files
-}