summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrii Kurdiumov <kant2002@gmail.com>2021-12-18 22:27:03 +0600
committerZac Medico <zmedico@gentoo.org>2021-12-18 11:13:58 -0800
commit0d205a08b0804d8f38470dc2c83cfb98ae809e95 (patch)
treea8cde4800afc45ebf5f26da98c697181d4847ec3 /dev-dotnet
parentwww-apps/icingaweb2: 2.9.5 stable amd64/x86 (diff)
downloadgentoo-0d205a08b0804d8f38470dc2c83cfb98ae809e95.tar.gz
gentoo-0d205a08b0804d8f38470dc2c83cfb98ae809e95.tar.bz2
gentoo-0d205a08b0804d8f38470dc2c83cfb98ae809e95.zip
dev-dotnet/dotnet-sdk-bin: Update .NET to 6.0.1
Closes: https://github.com/gentoo/gentoo/pull/23407 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/dotnet-sdk-bin/Manifest3
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.101.ebuild57
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-dotnet/dotnet-sdk-bin/Manifest b/dev-dotnet/dotnet-sdk-bin/Manifest
index 12a509241ee2..2f42bf703240 100644
--- a/dev-dotnet/dotnet-sdk-bin/Manifest
+++ b/dev-dotnet/dotnet-sdk-bin/Manifest
@@ -4,3 +4,6 @@ DIST dotnet-sdk-5.0.301-linux-x64.tar.gz 142255332 BLAKE2B 172888e2eb78d2f768cff
DIST dotnet-sdk-6.0.100-linux-arm.tar.gz 170285721 BLAKE2B b15484a3dd3472cd1b26b88b766b9bcc23bb9191cecde3052c619ef70337fae533b87610fb124d898d9c91645a76183ae27c4e073dcb3d9f599c2708305b3b5e SHA512 c1e555893c48c4f4256d3e6b1d36b31d8a4d7763a6e958fb63dd31436c660648d481612b5e25d79a613e84a1954f5eac2c9c2b740bf410958172780f7bbeaeb3
DIST dotnet-sdk-6.0.100-linux-arm64.tar.gz 168213476 BLAKE2B ae16caed1a9b7b50f1141dafd8b47001d7e8d1d166809c7db143d3386d420b43728c01e010cf14757290032dc7779997d28a5ed168ffe40e9ea7f2aed53cc9d1 SHA512 e5983c1c599d6dc7c3c7496b9698e47c68247f04a5d0d1e3162969d071471297bce1c2fd3a1f9fb88645006c327ae79f880dcbdd8eefc9166fd717331f2716e7
DIST dotnet-sdk-6.0.100-linux-x64.tar.gz 173759744 BLAKE2B fea1754290fbdbeb1e46a1e1e1f0b210010a5bee648d5a1e4a39cbe3d95d9903ba1f992ee5e3a9e410b622f9c058e316f16567f2df524dfbe8d230b383567b64 SHA512 cb0d174a79d6294c302261b645dba6a479da8f7cf6c1fe15ae6998bc09c5e0baec810822f9e0104e84b0efd51fdc0333306cb2a0a6fcdbaf515a8ad8cf1af25b
+DIST dotnet-sdk-6.0.101-linux-arm.tar.gz 169694030 BLAKE2B 71b13ebe3e7a108a808011c0ac9cae55cdc9c321a6884a194e26aa564dc421d7c2ee671f7fce1c18a6e06eea16837d54db0bdf9c93334a73245f8e8be412bbcd SHA512 f9e212dc4cccbe665d9aac23da6bdddce4957ae4e4d407cf3f1d6da7e79784ebd408c3a59b3ecc6ceaa930b37cf01a4a91c6b38517970d49227e96e50658cc46
+DIST dotnet-sdk-6.0.101-linux-arm64.tar.gz 167474911 BLAKE2B fed8915bd9564c271265b3f517ece94f3e5929fc8700d0a043e2dc1ccd8aa5fa3377371bf65d490c6c061be5409f61b66b91b4377f154450fd305fdb0d2f61ff SHA512 04cd89279f412ae6b11170d1724c6ac42bb5d4fae8352020a1f28511086dd6d6af2106dd48ebe3b39d312a21ee8925115de51979687a9161819a3a29e270a954
+DIST dotnet-sdk-6.0.101-linux-x64.tar.gz 173671008 BLAKE2B 340ddcfae67f2bbe4dd915c53977bb9b7b32c86837412a4fcb7edc78bb19584df94a893ae894141654547f4969486114addb0074383a5f09ff89c4534554c854 SHA512 ca21345400bcaceadad6327345f5364e858059cfcbc1759f05d7df7701fec26f1ead297b6928afa01e46db6f84e50770c673146a10b9ff71e4c7f7bc76fbf709
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.101.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.101.ebuild
new file mode 100644
index 000000000000..a52d40cfec34
--- /dev/null
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.101.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PV="${PV}"
+
+DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
+HOMEPAGE="https://dotnet.microsoft.com/"
+LICENSE="MIT"
+
+SRC_URI="
+amd64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-x64.tar.gz )
+arm? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm.tar.gz )
+arm64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm64.tar.gz )
+"
+
+SLOT="6.0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+dotnet-symlink"
+REQUIRED_USE="elibc_glibc"
+QA_PREBUILT="*"
+RESTRICT+=" splitdebug"
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-util/lttng-ust:0
+ sys-libs/zlib:0/1
+ dotnet-symlink? (
+ !dev-dotnet/dotnet-sdk[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-sdk-bin:5.0[dotnet-symlink(+)]
+ )
+"
+
+S=${WORKDIR}
+
+src_install() {
+ local dest="opt/${PN}-${SLOT}"
+ dodir "${dest%/*}"
+
+ # 6.0.100 is SDK feature band which will not change between minor increases, so 6.0.101, 6.102
+ # will still have same 6.0.100 SDK feature band in the name. Thus I have to hard code this
+ # https://github.com/dotnet/sdk/pull/18823#issuecomment-915603684
+ local workloads="metadata/workloads/${SLOT}.100"
+
+ { mkdir -p "${S}/${workloads}" && touch "${S}/${workloads}/userlocal"; } || die
+ { mv "${S}" "${ED}/${dest}" && mkdir "${S}" && fperms 0755 "/${dest}"; } || die
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SLOT}"
+
+ if use dotnet-symlink; then
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet"
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-${SLOT}"
+
+ # set an env-variable for 3rd party tools
+ echo "DOTNET_ROOT=/${dest}" > "${T}/90${PN}-${SLOT}" || die
+ doenvd "${T}/90${PN}-${SLOT}"
+ fi
+}