summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGergely Nagy <ngg@ngg.hu>2022-02-09 22:53:41 +0100
committerZac Medico <zmedico@gentoo.org>2022-02-12 11:56:49 -0800
commit5c80260b59bff39fdc304e7f900abff95123ff66 (patch)
tree904a4d81e97d2319bd13aee5eb7aa9253133f220 /dev-dotnet
parentdev-dotnet/dotnet-sdk-bin: bump to 5.0.405 (diff)
downloadgentoo-5c80260b59bff39fdc304e7f900abff95123ff66.tar.gz
gentoo-5c80260b59bff39fdc304e7f900abff95123ff66.tar.bz2
gentoo-5c80260b59bff39fdc304e7f900abff95123ff66.zip
dev-dotnet/dotnet-sdk-bin: bump to 6.0.102
Signed-off-by: Gergely Nagy <ngg@ngg.hu> Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/dotnet-sdk-bin/Manifest3
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.102.ebuild57
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-dotnet/dotnet-sdk-bin/Manifest b/dev-dotnet/dotnet-sdk-bin/Manifest
index a452863d5598..7618c6697449 100644
--- a/dev-dotnet/dotnet-sdk-bin/Manifest
+++ b/dev-dotnet/dotnet-sdk-bin/Manifest
@@ -10,3 +10,6 @@ DIST dotnet-sdk-6.0.100-linux-x64.tar.gz 173759744 BLAKE2B fea1754290fbdbeb1e46a
DIST dotnet-sdk-6.0.101-linux-arm.tar.gz 169694030 BLAKE2B 71b13ebe3e7a108a808011c0ac9cae55cdc9c321a6884a194e26aa564dc421d7c2ee671f7fce1c18a6e06eea16837d54db0bdf9c93334a73245f8e8be412bbcd SHA512 f9e212dc4cccbe665d9aac23da6bdddce4957ae4e4d407cf3f1d6da7e79784ebd408c3a59b3ecc6ceaa930b37cf01a4a91c6b38517970d49227e96e50658cc46
DIST dotnet-sdk-6.0.101-linux-arm64.tar.gz 167474911 BLAKE2B fed8915bd9564c271265b3f517ece94f3e5929fc8700d0a043e2dc1ccd8aa5fa3377371bf65d490c6c061be5409f61b66b91b4377f154450fd305fdb0d2f61ff SHA512 04cd89279f412ae6b11170d1724c6ac42bb5d4fae8352020a1f28511086dd6d6af2106dd48ebe3b39d312a21ee8925115de51979687a9161819a3a29e270a954
DIST dotnet-sdk-6.0.101-linux-x64.tar.gz 173671008 BLAKE2B 340ddcfae67f2bbe4dd915c53977bb9b7b32c86837412a4fcb7edc78bb19584df94a893ae894141654547f4969486114addb0074383a5f09ff89c4534554c854 SHA512 ca21345400bcaceadad6327345f5364e858059cfcbc1759f05d7df7701fec26f1ead297b6928afa01e46db6f84e50770c673146a10b9ff71e4c7f7bc76fbf709
+DIST dotnet-sdk-6.0.102-linux-arm.tar.gz 169190305 BLAKE2B 4f3aa3e2de89f8c360505c4287207bc285090f79e808e8b7637a3e92bbaaf69a6ea12c7296dfb729cb56a6c6e226ee276ff5e8776b439c140aeab5bcedd05824 SHA512 a72a0e81c62478b0dc662ef0aaeb7f96e7dd534e90b3ac1bdab1ca98dd93a4605881dba6e9ed2315781fdf71f5b33acb1aa5e28090c7a1693405bebed5853094
+DIST dotnet-sdk-6.0.102-linux-arm64.tar.gz 167109725 BLAKE2B e687b702ce7e2ad5f8abf87eb63716c2e29880b9fa8c10f37ede05f2d59f2426433549a8d535b71f7243f698a014871b6f2de8a2c2b06600bbe8a74fbdb4a8c5 SHA512 790cbf322ca8fed32eaf574f19d0bdc05656c5a88a65aa4dba8269cfce1443cd7cdeecdd3a40e353c368f055490b70592ca7f15f981a66c5b3a9517d0b09e4cb
+DIST dotnet-sdk-6.0.102-linux-x64.tar.gz 173139326 BLAKE2B cac49a69635c4f90bafc8e04b42c36e3196f6af8c39da152f16d771a3eff56fa39271c4af441a687cd9189031f6c68de3063a17aa1d21bc303a8172980c802de SHA512 edd79ebad3327032ea0aaa8504c14e3270050bb459b098202676776b41a3a1d282aaefd1e5e8aa09ef7f7cf7c4601c4783a57112ff6e3d427507e8eec2bfb748
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.102.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.102.ebuild
new file mode 100644
index 000000000000..a52d40cfec34
--- /dev/null
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.102.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PV="${PV}"
+
+DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
+HOMEPAGE="https://dotnet.microsoft.com/"
+LICENSE="MIT"
+
+SRC_URI="
+amd64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-x64.tar.gz )
+arm? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm.tar.gz )
+arm64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm64.tar.gz )
+"
+
+SLOT="6.0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+dotnet-symlink"
+REQUIRED_USE="elibc_glibc"
+QA_PREBUILT="*"
+RESTRICT+=" splitdebug"
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-util/lttng-ust:0
+ sys-libs/zlib:0/1
+ dotnet-symlink? (
+ !dev-dotnet/dotnet-sdk[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-sdk-bin:5.0[dotnet-symlink(+)]
+ )
+"
+
+S=${WORKDIR}
+
+src_install() {
+ local dest="opt/${PN}-${SLOT}"
+ dodir "${dest%/*}"
+
+ # 6.0.100 is SDK feature band which will not change between minor increases, so 6.0.101, 6.102
+ # will still have same 6.0.100 SDK feature band in the name. Thus I have to hard code this
+ # https://github.com/dotnet/sdk/pull/18823#issuecomment-915603684
+ local workloads="metadata/workloads/${SLOT}.100"
+
+ { mkdir -p "${S}/${workloads}" && touch "${S}/${workloads}/userlocal"; } || die
+ { mv "${S}" "${ED}/${dest}" && mkdir "${S}" && fperms 0755 "/${dest}"; } || die
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SLOT}"
+
+ if use dotnet-symlink; then
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet"
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-${SLOT}"
+
+ # set an env-variable for 3rd party tools
+ echo "DOTNET_ROOT=/${dest}" > "${T}/90${PN}-${SLOT}" || die
+ doenvd "${T}/90${PN}-${SLOT}"
+ fi
+}