summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2021-11-21 18:46:35 -0800
committerZac Medico <zmedico@gentoo.org>2021-11-21 18:46:35 -0800
commit60c54650b4e3b9064ad72ba64853992abe417eb7 (patch)
tree70bfb55350faf1a0d88355f83a9ad9e08e030ed4 /dev-dotnet
parentprofiles: fix typo in arm64 SELinux + systemd profile (diff)
downloadgentoo-60c54650b4e3b9064ad72ba64853992abe417eb7.tar.gz
gentoo-60c54650b4e3b9064ad72ba64853992abe417eb7.tar.bz2
gentoo-60c54650b4e3b9064ad72ba64853992abe417eb7.zip
dev-dotnet/dotnet-sdk-bin: Bump to version 6.0.100
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/dotnet-sdk-bin/Manifest3
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild51
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-dotnet/dotnet-sdk-bin/Manifest b/dev-dotnet/dotnet-sdk-bin/Manifest
index 0b7ac621e299..12a509241ee2 100644
--- a/dev-dotnet/dotnet-sdk-bin/Manifest
+++ b/dev-dotnet/dotnet-sdk-bin/Manifest
@@ -1,3 +1,6 @@
DIST dotnet-sdk-5.0.301-linux-arm.tar.gz 138735656 BLAKE2B c23732749f67bd2ca63cadba9bcb3f5abd4e10d00fed441825e6a59f9d3a3e663101502e5557dd94e737443cc9bbab0d5dbe8f7ebdbde54586596ec5c520a64f SHA512 89663ffb22299ad626d3f1d5129e493fb8784e6ed854b128a364407a060eec2979cd7d3c9e4f3df8e47ccb72b98ff8b18e8d53c7fb65b3455faa7344f67417a2
DIST dotnet-sdk-5.0.301-linux-arm64.tar.gz 136933875 BLAKE2B 6c48c8a2d47ba5bed47e6176d10e273ec996686cb5a4d5b3239098ff23d44526091f7eae1ce762a2eb2f6f31420cafda84471b936082469eadc8c62aa0dcd8bf SHA512 56e233b8f35abe80984bc8a60028f4f8dbc8543313a0711045ef13c693e11e706ee4809574518f57910ec2c93bed896da32760c8143a298556dc25478caca90f
DIST dotnet-sdk-5.0.301-linux-x64.tar.gz 142255332 BLAKE2B 172888e2eb78d2f768cff6a7e99d6473b469b7cbde74a4eab63e601d85bad118be374f330a413a9b6b3e6773340bdaef8ead4ed54a194189a50cac6b61fac556 SHA512 81cd7a3550a262d5c907030677429fa9a1cb515071274931ab760bd8bb2a14f40c9384c8757e1c1aa681b1de22035f16bf20b41ed208becd054cc9bb1f620322
+DIST dotnet-sdk-6.0.100-linux-arm.tar.gz 170285721 BLAKE2B b15484a3dd3472cd1b26b88b766b9bcc23bb9191cecde3052c619ef70337fae533b87610fb124d898d9c91645a76183ae27c4e073dcb3d9f599c2708305b3b5e SHA512 c1e555893c48c4f4256d3e6b1d36b31d8a4d7763a6e958fb63dd31436c660648d481612b5e25d79a613e84a1954f5eac2c9c2b740bf410958172780f7bbeaeb3
+DIST dotnet-sdk-6.0.100-linux-arm64.tar.gz 168213476 BLAKE2B ae16caed1a9b7b50f1141dafd8b47001d7e8d1d166809c7db143d3386d420b43728c01e010cf14757290032dc7779997d28a5ed168ffe40e9ea7f2aed53cc9d1 SHA512 e5983c1c599d6dc7c3c7496b9698e47c68247f04a5d0d1e3162969d071471297bce1c2fd3a1f9fb88645006c327ae79f880dcbdd8eefc9166fd717331f2716e7
+DIST dotnet-sdk-6.0.100-linux-x64.tar.gz 173759744 BLAKE2B fea1754290fbdbeb1e46a1e1e1f0b210010a5bee648d5a1e4a39cbe3d95d9903ba1f992ee5e3a9e410b622f9c058e316f16567f2df524dfbe8d230b383567b64 SHA512 cb0d174a79d6294c302261b645dba6a479da8f7cf6c1fe15ae6998bc09c5e0baec810822f9e0104e84b0efd51fdc0333306cb2a0a6fcdbaf515a8ad8cf1af25b
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild
new file mode 100644
index 000000000000..8f0c1a6de55f
--- /dev/null
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.100.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PV="${PV}"
+
+DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
+HOMEPAGE="https://dotnet.microsoft.com/"
+LICENSE="MIT"
+
+SRC_URI="
+amd64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-x64.tar.gz )
+arm? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm.tar.gz )
+arm64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm64.tar.gz )
+"
+
+SLOT="6.0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+dotnet-symlink"
+REQUIRED_USE="elibc_glibc"
+QA_PREBUILT="*"
+RESTRICT+=" splitdebug"
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-util/lttng-ust:0
+ sys-libs/zlib:0/1
+ dotnet-symlink? (
+ !dev-dotnet/dotnet-sdk[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-sdk-bin:5.0[dotnet-symlink(+)]
+ )
+"
+
+S=${WORKDIR}
+
+src_install() {
+ local dest="opt/${PN}-${SLOT}"
+ dodir "${dest%/*}"
+
+ { mv "${S}" "${ED}/${dest}" && mkdir "${S}" && fperms 0755 "/${dest}"; } || die
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SLOT}"
+
+ if use dotnet-symlink; then
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet"
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-${SLOT}"
+
+ # set an env-variable for 3rd party tools
+ echo "DOTNET_ROOT=/${dest}" > "${T}/90${PN}-${SLOT}" || die
+ doenvd "${T}/90${PN}-${SLOT}"
+ fi
+}