summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-08-13 17:06:20 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-08-13 17:13:48 +0200
commite8afac743410ddacf09bb0b44c6a447cd3225257 (patch)
tree43535b432d365996e3cb0a7d1bed539ff889fa38 /dev-dotnet
parentapp-shells/pwsh-bin: drop old 7.2.1-r1 (diff)
downloadgentoo-e8afac743410ddacf09bb0b44c6a447cd3225257.tar.gz
gentoo-e8afac743410ddacf09bb0b44c6a447cd3225257.tar.bz2
gentoo-e8afac743410ddacf09bb0b44c6a447cd3225257.zip
dev-dotnet/dotnet-sdk-bin: bump to 6.0.400
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/dotnet-sdk-bin/Manifest3
-rw-r--r--dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.400.ebuild65
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-dotnet/dotnet-sdk-bin/Manifest b/dev-dotnet/dotnet-sdk-bin/Manifest
index 64c3a66915a0..22cd580ceb8b 100644
--- a/dev-dotnet/dotnet-sdk-bin/Manifest
+++ b/dev-dotnet/dotnet-sdk-bin/Manifest
@@ -16,3 +16,6 @@ DIST dotnet-sdk-6.0.301-linux-x64.tar.gz 182966798 BLAKE2B ffc4e68efa9c1fbd8fe66
DIST dotnet-sdk-6.0.302-linux-arm.tar.gz 179253313 BLAKE2B faa9a1a7eafd261b4b7e47a3118cae1f5a47977d7b51d7eebb1c8ad1f42ebbe6c0baafe279f2df4b513c22b3450c80fcb338120edb660082bf9e0523ba3943f6 SHA512 0d31c7e8ccf02c8dea92d7b60bcb15e15912d74e7ee2ab8fd88ee03c4fbd8f292c356357d08ec23c2aedc5e3e0803d42ce16f3fff36245739d0cac6634bc3387
DIST dotnet-sdk-6.0.302-linux-arm64.tar.gz 176713012 BLAKE2B 685a08373753cf5d4ff05d783429248a5411cffebc80e137cad690168c29dc981612aadac025ad8c076cd0ad6f8faf574ae25dc1fe7d3aad4c51b7da264532e8 SHA512 26e98a63665d707b1a7729f1794077316f9927edd88d12d82d0357fe597096b0d89b64a085fcdf0cf49807a443bbfebb48e10ea91cea890846cf4308e67c4ea5
DIST dotnet-sdk-6.0.302-linux-x64.tar.gz 183170672 BLAKE2B b4760bc5487dd791c5e61a70693bbcdfc84d1f597dbb0c3f10b8389de761a96fbf92e1b3bcff814e240222045c4532fa19af738b4e8017988bf8d1e39e3a7ea4 SHA512 ac1d124802ca035aa00806312460b371af8e3a55d85383ddd8bb66f427c4fabae75b8be23c45888344e13b283a4f9c7df228447c06d796a57ffa5bb21992e6a4
+DIST dotnet-sdk-6.0.400-linux-arm.tar.gz 181255234 BLAKE2B af46ca19f09c690ff28ee02e273fae3113b6450028d4ff30798aaa796932f12f6082f919cfa116cf1e12f9a4674187e1da1a90d6646bf62212376e86cb1d5b69 SHA512 a72aa70bfb15e21a20ddd90c2c3e37acb53e6f1e50f5b6948aac616b28f80ac81e1157e8db5688e21dc9a7496011ef0fcf06cdca74ddc7271f9a1c6268f4b1b2
+DIST dotnet-sdk-6.0.400-linux-arm64.tar.gz 178978691 BLAKE2B a9a4d9acaca85766be37e9939170f16751e08085ca19dc5b892ce33abcbdde274a023de4326704c016709000aa1771fac8fc1de7dae52c727496ff0ef6444860 SHA512 a21010f9e0e091bf0a4df9dfc4ec9893c056c2b07b10be093ea392a4fa5c8a38bad9535f66e570b45dc25165b685199fb729434b845bcfb35f8b79cceb22c632
+DIST dotnet-sdk-6.0.400-linux-x64.tar.gz 185123905 BLAKE2B 84a4df49516cf9e1185b59ac840c54f27c3c1d5b6f3ab22db0756d24c72ea30842ceeca5e4ddc40ecd0efb4f84dbe794ba32568769459f9797e7006419276645 SHA512 8decbba0a6b09501daede52cbb5a9ae9e5f31ade201918c03efcd1b4cc345ec934f88321704ec3beb1f90f2204934be7259c76f66d9204cbdd15933582602763
diff --git a/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.400.ebuild b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.400.ebuild
new file mode 100644
index 000000000000..bfdeb499a7c5
--- /dev/null
+++ b/dev-dotnet/dotnet-sdk-bin/dotnet-sdk-bin-6.0.400.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+MY_PV="${PV}"
+
+DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
+HOMEPAGE="https://dotnet.microsoft.com/"
+LICENSE="MIT"
+
+SRC_URI="
+amd64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-x64.tar.gz )
+arm? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm.tar.gz )
+arm64? ( https://dotnetcli.azureedge.net/dotnet/Sdk/${MY_PV}/dotnet-sdk-${MY_PV}-linux-arm64.tar.gz )
+"
+
+SLOT="6.0"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+dotnet-symlink"
+REQUIRED_USE="elibc_glibc"
+QA_PREBUILT="*"
+RESTRICT+=" splitdebug"
+RDEPEND="
+ app-crypt/mit-krb5:0/0
+ dev-util/lttng-ust:0
+ sys-libs/zlib:0/1
+ dotnet-symlink? (
+ !dev-dotnet/dotnet-sdk[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-sdk-bin:3.1[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-sdk-bin:5.0[dotnet-symlink(+)]
+ )
+"
+
+S=${WORKDIR}
+
+src_install() {
+ local dest="opt/${PN}-${SLOT}"
+ dodir "${dest%/*}"
+
+ # Create a magic workloads file, bug #841896
+ local featureband="$(ver_cut 3 | sed "s/[0-9]/0/2g")"
+ local workloads="metadata/workloads/${SLOT}.${featureband}"
+ { mkdir -p "${S}/${workloads}" && touch "${S}/${workloads}/userlocal"; } || die
+
+ { mv "${S}" "${ED}/${dest}" && mkdir "${S}" && fperms 0755 "/${dest}"; } || die
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SLOT}"
+
+ if use dotnet-symlink; then
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet"
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-${SLOT}"
+
+ # set an env-variable for 3rd party tools
+ echo "DOTNET_ROOT=/${dest}" > "${T}/90${PN}-${SLOT}" || die
+ doenvd "${T}/90${PN}-${SLOT}"
+ fi
+}
+
+pkg_postinst() {
+ # For bug #833281 Also, MS docs:
+ # https://docs.microsoft.com/en-us/dotnet/core/runtime-config/globalization
+ optfeature "globalization support" dev-libs/icu
+}