summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-27 19:50:10 +0000
committerSam James <sam@gentoo.org>2020-12-27 20:19:33 +0000
commitec756fc35c98d20a36e8a239612998148a7b9e29 (patch)
treeb6c8e598d070a132bab20634175a31c1755cef41 /dev-embedded/libftdi/libftdi-9999.ebuild
parentsys-apps/dbus: drop sysusers.d file (diff)
downloadgentoo-ec756fc35c98d20a36e8a239612998148a7b9e29.tar.gz
gentoo-ec756fc35c98d20a36e8a239612998148a7b9e29.tar.bz2
gentoo-ec756fc35c98d20a36e8a239612998148a7b9e29.zip
dev-embedded/libftdi: bump to 1.5
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-embedded/libftdi/libftdi-9999.ebuild')
-rw-r--r--dev-embedded/libftdi/libftdi-9999.ebuild29
1 files changed, 20 insertions, 9 deletions
diff --git a/dev-embedded/libftdi/libftdi-9999.ebuild b/dev-embedded/libftdi/libftdi-9999.ebuild
index a85450a924cf..4ad4a4e4baf1 100644
--- a/dev-embedded/libftdi/libftdi-9999.ebuild
+++ b/dev-embedded/libftdi/libftdi-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python3_{6,7,8,9} )
-inherit cmake-utils python-single-r1
+inherit cmake python-single-r1
MY_P="${PN}1-${PV}"
if [[ ${PV} == 9999* ]] ; then
@@ -17,6 +17,7 @@ fi
DESCRIPTION="Userspace access to FTDI USB interface chips"
HOMEPAGE="https://www.intra2net.com/en/developer/libftdi/"
+S="${WORKDIR}/${MY_P}"
LICENSE="LGPL-2"
SLOT="1"
@@ -24,6 +25,10 @@ IUSE="cxx doc examples python static-libs test tools"
RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+BDEPEND="
+ doc? ( app-doc/doxygen )
+ python? ( dev-lang/swig )
+"
RDEPEND="virtual/libusb:1
cxx? ( dev-libs/boost )
python? ( ${PYTHON_DEPS} )
@@ -31,16 +36,16 @@ RDEPEND="virtual/libusb:1
!<dev-embedded/ftdi_eeprom-1.0
dev-libs/confuse:=
)"
-DEPEND="${RDEPEND}
- python? ( dev-lang/swig )
- doc? ( app-doc/doxygen )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/libftdi-1.5-cmake-git.patch"
+)
pkg_setup() {
use python && python-single-r1_pkg_setup
}
-S=${WORKDIR}/${MY_P}
-
src_configure() {
local mycmakeargs=(
-DFTDIPP=$(usex cxx)
@@ -52,11 +57,16 @@ src_configure() {
-DFTDI_EEPROM=$(usex tools)
-DCMAKE_SKIP_BUILD_RPATH=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${BUILD_DIR}/test" || die
+ ./test_libftdi1 -l all || die
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
use python && python_optimize
dodoc AUTHORS ChangeLog README TODO
@@ -67,6 +77,7 @@ src_install() {
doman "${CMAKE_BUILD_DIR}"/doc/man/man3/*
dodoc -r "${CMAKE_BUILD_DIR}"/doc/html
fi
+
if use examples ; then
docinto examples
dodoc examples/*.c