summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-10-20 13:18:37 +0200
committerPacho Ramos <pacho@gentoo.org>2018-10-20 13:39:03 +0200
commit6b3e2769dc5c411be32b933bdafd3b6976a31c63 (patch)
treeb3cc168c456bd5d21f5b0a5f2f885ea86eb1efb7 /dev-embedded/mcu8051ide/mcu8051ide-1.4.10.ebuild
parentapp-arch/rpm: Drop old (diff)
downloadgentoo-6b3e2769dc5c411be32b933bdafd3b6976a31c63.tar.gz
gentoo-6b3e2769dc5c411be32b933bdafd3b6976a31c63.tar.bz2
gentoo-6b3e2769dc5c411be32b933bdafd3b6976a31c63.zip
dev-embedded/mcu8051ide: Upstream resources disappeared
Closes: https://bugs.gentoo.org/636754 Signed-off-by: Pacho Ramos <pacho@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-embedded/mcu8051ide/mcu8051ide-1.4.10.ebuild')
-rw-r--r--dev-embedded/mcu8051ide/mcu8051ide-1.4.10.ebuild35
1 files changed, 18 insertions, 17 deletions
diff --git a/dev-embedded/mcu8051ide/mcu8051ide-1.4.10.ebuild b/dev-embedded/mcu8051ide/mcu8051ide-1.4.10.ebuild
index 73b38e60146a..8d2c46293886 100644
--- a/dev-embedded/mcu8051ide/mcu8051ide-1.4.10.ebuild
+++ b/dev-embedded/mcu8051ide/mcu8051ide-1.4.10.ebuild
@@ -1,29 +1,30 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
-
+EAPI=6
inherit cmake-utils
DESCRIPTION="Graphical IDE for microcontrollers based on 8051."
-HOMEPAGE="http://www.moravia-microsystems.com/mcu-8051-ide/"
-SRC_URI="http://www.moravia-microsystems.com/download/${PN}/${PN}/${PV}/${P}.tar.gz"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64"
# The doxygen dependency is suspect, but it appears to be used at runtime.
-RDEPEND=">=dev-embedded/sdcc-2.5[mcs51]
- >=app-doc/doxygen-1.7
- >=dev-util/indent-2.2
- >=app-text/hunspell-1.3
- >=dev-tcltk/bwidget-1.8
- >dev-tcltk/itcl-3.3
- >=dev-lang/tcl-8.5.9:*
- >=dev-tcltk/tdom-0.8
- >=dev-tcltk/tcllib-1.11
- >=dev-lang/tk-8.5.9:*
- >=dev-tcltk/tkimg-1.4
- >=dev-tcltk/tclx-8.4"
+RDEPEND="
+ >=dev-embedded/sdcc-2.5[mcs51]
+ >=app-doc/doxygen-1.7
+ >=dev-util/indent-2.2
+ >=app-text/hunspell-1.3
+ >=dev-tcltk/bwidget-1.8
+ >dev-tcltk/itcl-3.3
+ >=dev-lang/tcl-8.5.9:*
+ >=dev-tcltk/tdom-0.8
+ >=dev-tcltk/tcllib-1.11
+ >=dev-lang/tk-8.5.9:*
+ >=dev-tcltk/tkimg-1.4
+ >=dev-tcltk/tclx-8.4
+"
DEPEND="${RDEPEND}"