summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/picasm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/picasm')
-rw-r--r--dev-embedded/picasm/Manifest1
-rw-r--r--dev-embedded/picasm/metadata.xml5
-rw-r--r--dev-embedded/picasm/picasm-1.14.ebuild42
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-embedded/picasm/Manifest b/dev-embedded/picasm/Manifest
new file mode 100644
index 000000000000..0e1b2c053814
--- /dev/null
+++ b/dev-embedded/picasm/Manifest
@@ -0,0 +1 @@
+DIST picasm114.tar.bz2 35429 SHA256 6ff69880256953f4c55aa29e48714e81ebd9fd6ce1e81090fae1fb929902dfb8 SHA512 a6a8490156afe8af1fc85700890570c745c076396890491f4efe004d7dd701a324f9c7e764fcc710c8954c761f3abb4ed8e97c72ce098100192ead334b335fb7 WHIRLPOOL 587461e5670fad49a1be9f464079cc32466e28b44b108b58445d24bfd3adc981d6aba37d6167f4279d8c70831c5d8a836dd8f4969c3b28a588206560bda5d21f
diff --git a/dev-embedded/picasm/metadata.xml b/dev-embedded/picasm/metadata.xml
new file mode 100644
index 000000000000..92114080841c
--- /dev/null
+++ b/dev-embedded/picasm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-embedded</herd>
+</pkgmetadata>
diff --git a/dev-embedded/picasm/picasm-1.14.ebuild b/dev-embedded/picasm/picasm-1.14.ebuild
new file mode 100644
index 000000000000..36cd3fd3b731
--- /dev/null
+++ b/dev-embedded/picasm/picasm-1.14.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs flag-o-matic
+
+MY_PV="${PV//.}"
+MY_P="${PN}${MY_PV}"
+DESCRIPTION="An assembler and disassembler for 12 and 14-bit PIC chips"
+HOMEPAGE="http://www.iki.fi/trossi/pic/"
+SRC_URI="http://www.iki.fi/trossi/pic/${MY_P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e 's:$(CC):\0 $(LDFLAGS):' Makefile || die
+}
+
+src_compile() {
+ append-cflags -DBUILTIN_INCLUDE1=\\\"/usr/share/picasm/include\\\"
+ emake CFLAGS="${CFLAGS}" CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin picasm
+ dodoc picasm.txt HISTORY TODO
+
+ insinto /usr/share/picasm/include
+ doins device_definitions/*.i
+
+ dohtml picasm.html
+ docinto examples
+ dodoc examples/*.*
+ docompress -x /usr/share/doc/${PF}/examples
+}