summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/tavrasm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/tavrasm')
-rw-r--r--dev-embedded/tavrasm/Manifest1
-rw-r--r--dev-embedded/tavrasm/files/tavrasm-1.22-gentoo.patch25
-rw-r--r--dev-embedded/tavrasm/metadata.xml5
-rw-r--r--dev-embedded/tavrasm/tavrasm-1.22-r1.ebuild39
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-embedded/tavrasm/Manifest b/dev-embedded/tavrasm/Manifest
new file mode 100644
index 000000000000..62d14685bbd5
--- /dev/null
+++ b/dev-embedded/tavrasm/Manifest
@@ -0,0 +1 @@
+DIST tavrasm-1.22.tar.gz 65685 SHA256 a2597fc6e18980edc0f33e8651b0f0df725ca2441eb39c5e2bbd1c82a1c009c7 SHA512 0f33607e2ffbe8c56268b15dc62fe6c2b565bf898c68e198846f11fb30da4da3f398d07ef7ac16050dbc92ffcb04612459027a2c27cf48fc7d74392c5f6a38dc WHIRLPOOL a0bf2122fce095964ed0bd2afd574de7bcf904622967721a3b54efe1243dcf41209935777f7803059af5a6f55a2cf6236ad39a5b19c3a2dec47b300adfd0b4f2
diff --git a/dev-embedded/tavrasm/files/tavrasm-1.22-gentoo.patch b/dev-embedded/tavrasm/files/tavrasm-1.22-gentoo.patch
new file mode 100644
index 000000000000..f752c715d32d
--- /dev/null
+++ b/dev-embedded/tavrasm/files/tavrasm-1.22-gentoo.patch
@@ -0,0 +1,25 @@
+* Do not set CC
+* Adhere to CFLAGS and LDFLAGS, do not set optimisation flags
+
+
+--- a/src/makefile 2004-12-12 00:51:29.000000000 +0100
++++ b/src/makefile 2010-05-07 03:26:38.000000000 +0200
+@@ -24,8 +24,7 @@
+
+ ### Compiler options #########################################################
+
+-CC = gcc
+-CFLAGS = -O2 -Wall -DAVRLANG=LANGUAGE_$(LANGUAGE)
++CFLAGS += -Wall -DAVRLANG=LANGUAGE_$(LANGUAGE)
+ CPPFLAGS =
+ CCFLAGS = $(CFLAGS) $(CPPFLAGS)
+ LINK = -lm -lstdc++
+@@ -39,7 +38,7 @@
+ ### Executable ##############################################################
+
+ $(EXENAME): $(OBJS)
+- $(CC) $(CCFLAGS) $(OBJS) $(LINK) -o $@
++ $(CC) $(CCFLAGS) $(LDFLAGS) $(OBJS) $(LINK) -o $@
+
+ ### Parser file #############################################################
+
diff --git a/dev-embedded/tavrasm/metadata.xml b/dev-embedded/tavrasm/metadata.xml
new file mode 100644
index 000000000000..a217d236ec3d
--- /dev/null
+++ b/dev-embedded/tavrasm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dev-embedded</herd>
+</pkgmetadata>
diff --git a/dev-embedded/tavrasm/tavrasm-1.22-r1.ebuild b/dev-embedded/tavrasm/tavrasm-1.22-r1.ebuild
new file mode 100644
index 000000000000..75045f1ada9e
--- /dev/null
+++ b/dev-embedded/tavrasm/tavrasm-1.22-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs versionator
+
+DESCRIPTION="Compiles code written for Atmels AVR DOS assembler"
+HOMEPAGE="http://www.tavrasm.org/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND="
+ sys-devel/bison
+ sys-devel/flex"
+RDEPEND=""
+
+S="${WORKDIR}/${PN}.$(delete_all_version_separators ${PV})"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_compile() {
+ tc-export CC
+ cd src
+
+ # The Makefile of tavrasm is stupid, hence the -j1
+ emake -j1 || die "Compilation failed"
+}
+
+src_install() {
+ dobin src/tavrasm || die "dobin failed"
+ doman tavrasm.1
+ dodoc README
+}