summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/zmac
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/zmac')
-rw-r--r--dev-embedded/zmac/Manifest1
-rw-r--r--dev-embedded/zmac/metadata.xml16
-rw-r--r--dev-embedded/zmac/zmac-1.3.ebuild29
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-embedded/zmac/Manifest b/dev-embedded/zmac/Manifest
new file mode 100644
index 000000000000..d7ea68508ee3
--- /dev/null
+++ b/dev-embedded/zmac/Manifest
@@ -0,0 +1 @@
+DIST zmac13.zip 82067 SHA256 02cc3f487f82632ce558b512c482789cbc8f39bba8d8d3650a43c36c68f9aaff SHA512 84c1206e3abf19809ab4358c0b5d46771cdcfdeb4ded14aa39d81ca7f9d3780ca1917823bd06f49ee9fafaaa079bdbe8b614ce842d44181f55d4287515a187a2 WHIRLPOOL 8ee06662ecabc85a7a3ff5876c28144e1a7eaf6d1b3c68e24eca5ef8918539311261bedb705dcade90ab00bf8e29f1b1f836a191017d3dc64f2c0bc215bd4e5a
diff --git a/dev-embedded/zmac/metadata.xml b/dev-embedded/zmac/metadata.xml
new file mode 100644
index 000000000000..8a1942bec228
--- /dev/null
+++ b/dev-embedded/zmac/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>ulm@gentoo.org</email>
+</maintainer>
+<longdescription>
+ zmac is a Z80 macro cross-assembler. It has all the features you'd expect.
+ It assembles the specified input file and produces raw binary output.
+ (It can optionally produce CP/M-style Intel hex format.) By default it
+ also produces a nicely-formatted listing of the m/c alongside the source.
+
+ As well as normal Z80 programs, zmac lets you write 8080 programs in Z80
+ assembly.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-embedded/zmac/zmac-1.3.ebuild b/dev-embedded/zmac/zmac-1.3.ebuild
new file mode 100644
index 000000000000..9f503592117e
--- /dev/null
+++ b/dev-embedded/zmac/zmac-1.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="Z80 macro cross-assembler"
+HOMEPAGE="http://www.tim-mann.org/trs80resources.html"
+SRC_URI="http://www.tim-mann.org/trs80/${PN}${PV//.}.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin zmac || die
+ doman zmac.1 || die
+ dodoc ChangeLog MAXAM NEWS README || die
+}