summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-embedded
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/libftdi/libftdi-1.2-r1.ebuild1
-rw-r--r--dev-embedded/libftdi/libftdi-1.2-r2.ebuild1
-rw-r--r--dev-embedded/libftdi/libftdi-1.4.ebuild1
-rw-r--r--dev-embedded/libftdi/libftdi-9999.ebuild1
-rw-r--r--dev-embedded/srecord/srecord-1.64.ebuild3
5 files changed, 6 insertions, 1 deletions
diff --git a/dev-embedded/libftdi/libftdi-1.2-r1.ebuild b/dev-embedded/libftdi/libftdi-1.2-r1.ebuild
index afda699e90b2..87d2acd1869e 100644
--- a/dev-embedded/libftdi/libftdi-1.2-r1.ebuild
+++ b/dev-embedded/libftdi/libftdi-1.2-r1.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
LICENSE="LGPL-2"
SLOT="1"
IUSE="cxx doc examples python static-libs test tools"
+RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="virtual/libusb:1
diff --git a/dev-embedded/libftdi/libftdi-1.2-r2.ebuild b/dev-embedded/libftdi/libftdi-1.2-r2.ebuild
index bab08a925d35..b96024a4ce0c 100644
--- a/dev-embedded/libftdi/libftdi-1.2-r2.ebuild
+++ b/dev-embedded/libftdi/libftdi-1.2-r2.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
LICENSE="LGPL-2"
SLOT="1"
IUSE="cxx doc examples python static-libs test tools"
+RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="virtual/libusb:1
diff --git a/dev-embedded/libftdi/libftdi-1.4.ebuild b/dev-embedded/libftdi/libftdi-1.4.ebuild
index bab08a925d35..b96024a4ce0c 100644
--- a/dev-embedded/libftdi/libftdi-1.4.ebuild
+++ b/dev-embedded/libftdi/libftdi-1.4.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
LICENSE="LGPL-2"
SLOT="1"
IUSE="cxx doc examples python static-libs test tools"
+RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="virtual/libusb:1
diff --git a/dev-embedded/libftdi/libftdi-9999.ebuild b/dev-embedded/libftdi/libftdi-9999.ebuild
index bab08a925d35..b96024a4ce0c 100644
--- a/dev-embedded/libftdi/libftdi-9999.ebuild
+++ b/dev-embedded/libftdi/libftdi-9999.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
LICENSE="LGPL-2"
SLOT="1"
IUSE="cxx doc examples python static-libs test tools"
+RESTRICT="!test? ( test )"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="virtual/libusb:1
diff --git a/dev-embedded/srecord/srecord-1.64.ebuild b/dev-embedded/srecord/srecord-1.64.ebuild
index beccea452409..c99b340b5198 100644
--- a/dev-embedded/srecord/srecord-1.64.ebuild
+++ b/dev-embedded/srecord/srecord-1.64.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,7 @@ LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~sparc ~x86"
IUSE="static-libs test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-libs/libgcrypt:0"
DEPEND="${RDEPEND}