summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <hsoft@hardcoded.net>2018-02-12 15:14:28 -0500
committerAmy Liffey <amynka@gentoo.org>2018-03-06 20:58:46 +0100
commitbfad65bf874204c009b6efa52548bdd8c12b3f30 (patch)
treeb38e713770f732dd592ee13382ee5380de28c9ac /dev-embedded
parentnet-misc/quagga: arm stable, bug #647788 (diff)
downloadgentoo-bfad65bf874204c009b6efa52548bdd8c12b3f30.tar.gz
gentoo-bfad65bf874204c009b6efa52548bdd8c12b3f30.tar.bz2
gentoo-bfad65bf874204c009b6efa52548bdd8c12b3f30.zip
dev-embedded/arduino-ctags: new package
This package is needed for the bump of dev-embedded/arduino to 1.8.5. It uses its own private fork of ctags and when using dev-util/ctags, arduino produces non-functioning executables. Bug: https://bugs.gentoo.org/525882 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/arduino-ctags/Manifest1
-rw-r--r--dev-embedded/arduino-ctags/arduino-ctags-20161123.ebuild30
-rw-r--r--dev-embedded/arduino-ctags/metadata.xml17
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-embedded/arduino-ctags/Manifest b/dev-embedded/arduino-ctags/Manifest
new file mode 100644
index 000000000000..8398798df86e
--- /dev/null
+++ b/dev-embedded/arduino-ctags/Manifest
@@ -0,0 +1 @@
+DIST arduino-ctags-20161123.tar.gz 490200 BLAKE2B f51b18a0db420124c5fed2b320c16d9eeb96fce6d0f118cf43a8177f88400daaeb83437c3993353c16b73781961c7476e782e66891582f4b3dc5301c73da64dc SHA512 ae5bde92c3dd0b9a179bc1df998f20312c4ab8b2c9c1840dbe543d23fb4531b9e5524f1399d9922ed9b2de4582bdb74635f7ec576a42c808d152c3fbb84f9687
diff --git a/dev-embedded/arduino-ctags/arduino-ctags-20161123.ebuild b/dev-embedded/arduino-ctags/arduino-ctags-20161123.ebuild
new file mode 100644
index 000000000000..e2bcd0810ab1
--- /dev/null
+++ b/dev-embedded/arduino-ctags/arduino-ctags-20161123.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+COMMITHASH="abc8fca7499f44c725122881cd380a88c37abe0e"
+
+DESCRIPTION="Arduino private fork of dev-util/ctags"
+HOMEPAGE="https://github.com/arduino/ctags"
+SRC_URI="https://github.com/arduino/ctags/archive/${COMMITHASH}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/ctags-${COMMITHASH}"
+
+src_configure() {
+ econf \
+ --disable-readlib \
+ --disable-etags \
+ --enable-tmpdir="${EPREFIX}"/tmp
+}
+
+src_install() {
+ # This package compiles into a "ctags" executable, but don't want to clash into
+ # actually legitimate ctags implementations.
+ mv ctags arduino-ctags
+ dobin arduino-ctags
+}
diff --git a/dev-embedded/arduino-ctags/metadata.xml b/dev-embedded/arduino-ctags/metadata.xml
new file mode 100644
index 000000000000..6e4776276159
--- /dev/null
+++ b/dev-embedded/arduino-ctags/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>embedded@gentoo.org</email>
+ <name>Embedded Gentoo</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">arduino/ctags</remote-id>
+ </upstream>
+ <longdescription>
+ Arduino's build process includes a preprocessing phase that involves ctags,
+ but not any version of ctags, *Arduino's* ctags, a private fork that
+ Arduino maintains. We can't use dev-util/ctags because it causes Arduino
+ to produce corrupt executables.
+ </longdescription>
+</pkgmetadata>