summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-05-07 23:19:49 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-05-07 23:20:53 +0200
commitea86ff88c494c3551724324f4f48d0cc5b79d595 (patch)
tree7792914cf1783b788a509572c1735e316b82d48e /dev-embedded
parentdev-vcs/python-gitlab: 2.2.0 bump (diff)
downloadgentoo-ea86ff88c494c3551724324f4f48d0cc5b79d595.tar.gz
gentoo-ea86ff88c494c3551724324f4f48d0cc5b79d595.tar.bz2
gentoo-ea86ff88c494c3551724324f4f48d0cc5b79d595.zip
dev-embedded/esptool: Drop 2.1 and 2.6, py36-only
No maintainer, no more stable. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/esptool/Manifest2
-rw-r--r--dev-embedded/esptool/esptool-2.1.ebuild29
-rw-r--r--dev-embedded/esptool/esptool-2.6.ebuild37
3 files changed, 0 insertions, 68 deletions
diff --git a/dev-embedded/esptool/Manifest b/dev-embedded/esptool/Manifest
index 61a54ed70245..9aabd42d1b85 100644
--- a/dev-embedded/esptool/Manifest
+++ b/dev-embedded/esptool/Manifest
@@ -1,3 +1 @@
-DIST esptool-2.1.tar.gz 68974 BLAKE2B 4aaddc9bf22a624de18e7d58b35a42f6fa27cf8bdfff119a270b9531f1e19ecb3f4d7eebad319a799068a19941bf0c843fc464fd5ae891d8e03e1a2bad54dd68 SHA512 be657df04a345d2c91bbe3a9cbb93cd7bb0bc68e61388ff4d134c88d514c74fe3f2c5e7c64f4100264bc5973b1d3e66251cdb16a77894fb9e116d9c6a54a8dc3
-DIST esptool-2.6.tar.gz 4336261 BLAKE2B 1da9ea1ed24d1bf91e2bbac079016c4813012946977ca6da7f6b4eac52ea77f501f4185efca39a636cab438720f0a14ca2faf49920228656fcb4786690824208 SHA512 dd2e1815df07a491d5b41b709aafecb642f5b642c83b11e309986ba0ad827257e6b7bb93f4decd7ee37fd10a1ee7b36c836598c0c2e1e60118bf96397c187dfd
DIST esptool-2.8.tar.gz 5399875 BLAKE2B c2c27dc44cec1921f2d800347682bb198be76f7a122fd6a0c9964fb189350980557aa85bd6cb8fb2d63c8c7ccdd18e1860b65ca85c8777145ec1da07da886be1 SHA512 14528197e760779f3bf50e2a44d477979675dd42451fa405e2ae87502158b21f999fb94561980c9eb0634d2d1fd3729779b78266403de858ed1d32e8d29604cc
diff --git a/dev-embedded/esptool/esptool-2.1.ebuild b/dev-embedded/esptool/esptool-2.1.ebuild
deleted file mode 100644
index 3b19277c6feb..000000000000
--- a/dev-embedded/esptool/esptool-2.1.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
-HOMEPAGE="https://github.com/espressif/esptool"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~x86"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}
- dev-python/ecdsa[${PYTHON_USEDEP}]
- dev-python/pyaes[${PYTHON_USEDEP}]
- >=dev-python/pyserial-2.5[${PYTHON_USEDEP}]"
-
-RESTRICT="test" # Uses a device connected to the serial port
-
-python_test() {
- ${EPYTHON} test/test_esptool.py || die
-}
diff --git a/dev-embedded/esptool/esptool-2.6.ebuild b/dev-embedded/esptool/esptool-2.6.ebuild
deleted file mode 100644
index 3b0512e262a6..000000000000
--- a/dev-embedded/esptool/esptool-2.6.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Utility to communicate with the ROM bootloader in Espressif ESP8266 and ESP32"
-HOMEPAGE="https://github.com/espressif/esptool"
-SRC_URI="https://github.com/espressif/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-RDEPEND="
- dev-python/ecdsa[${PYTHON_USEDEP}]
- dev-python/pyaes[${PYTHON_USEDEP}]
- >=dev-python/pyserial-3.0[${PYTHON_USEDEP}]
-"
-
-DEPEND="
- test? ( ${RDEPEND}
- dev-python/pyelftools[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- ${EPYTHON} test/test_imagegen.py || die "imagegen test failed with ${EPYTHON}"
- ${EPYTHON} test/test_espsecure.py || die "espsecure test failed with ${EPYTHON}"
-}