summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-08-20 12:25:53 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-08-20 12:32:32 +0300
commitfe453a409dd2b034da85b391dcb8b7b8920bb573 (patch)
tree1a015e2d0c94c23514ea92b359b369e35e36a69d /dev-embedded
parentdev-embedded/libftdi: fix slots collision (diff)
downloadgentoo-fe453a409dd2b034da85b391dcb8b7b8920bb573.tar.gz
gentoo-fe453a409dd2b034da85b391dcb8b7b8920bb573.tar.bz2
gentoo-fe453a409dd2b034da85b391dcb8b7b8920bb573.zip
dev-embedded/jal: fix clang-16 issue
Update EAPI 7 -> 8. Add autoreconf to fix autoconf failure with clang-16. Closes: https://bugs.gentoo.org/906345 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/jal/jal-0.4.62-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-embedded/jal/jal-0.4.62-r1.ebuild b/dev-embedded/jal/jal-0.4.62-r1.ebuild
index efadbb6cadd9..92343e68b945 100644
--- a/dev-embedded/jal/jal-0.4.62-r1.ebuild
+++ b/dev-embedded/jal/jal-0.4.62-r1.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+inherit autotools
DESCRIPTION="A high-level language for Microchip PIC and Ubicom SX microcontrollers"
HOMEPAGE="https://jal.sourceforge.net/"
@@ -16,3 +18,8 @@ S="${WORKDIR}/${PN}"
PATCHES=(
"${FILESDIR}"/${PN}-0.4.62-fix-incompatible-integer-to-pointer-clang16.patch
)
+
+src_prepare() {
+ default
+ eautoreconf
+}