summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Żołnowski <aidecoe@gentoo.org>2016-08-29 22:18:09 +0100
committerAmadeusz Żołnowski <aidecoe@gentoo.org>2016-08-29 22:19:13 +0100
commit9744a548180b1fb11a1d165e953348635c1ec156 (patch)
tree65cd57be610044516b38bf6020573eafc9f6feef /dev-erlang/protobuffs/protobuffs-0.9.0.ebuild
parentdev-erlang/hamcrest: Bump version to latest (diff)
downloadgentoo-9744a548180b1fb11a1d165e953348635c1ec156.tar.gz
gentoo-9744a548180b1fb11a1d165e953348635c1ec156.tar.bz2
gentoo-9744a548180b1fb11a1d165e953348635c1ec156.zip
dev-erlang/protobuffs: Bump version to 0.9.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-erlang/protobuffs/protobuffs-0.9.0.ebuild')
-rw-r--r--dev-erlang/protobuffs/protobuffs-0.9.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-erlang/protobuffs/protobuffs-0.9.0.ebuild b/dev-erlang/protobuffs/protobuffs-0.9.0.ebuild
new file mode 100644
index 000000000000..8ae511da4257
--- /dev/null
+++ b/dev-erlang/protobuffs/protobuffs-0.9.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit rebar
+
+MY_PN="erlang_protobuffs"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Google's Protocol Buffers for Erlang"
+HOMEPAGE="https://github.com/basho/erlang_protobuffs"
+SRC_URI="https://github.com/basho/${MY_PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-lang/erlang-17.1"
+DEPEND="${CDEPEND}
+ test? (
+ >=dev-erlang/meck-0.8.2
+ >=dev-erlang/proper-1.1
+ )"
+RDEPEND="${CDEPEND}"
+
+DOCS=( AUTHORS ChangeLog README.md RELNOTES.md )
+
+S="${WORKDIR}/${MY_P}"
+
+src_test() {
+ ./scripts/generate_emakefile.escript || die
+ erebar ct
+ # FIXME: 1 test fails, reported upstream:
+ # FIXME: https://github.com/basho/erlang_protobuffs/issues/100
+ # FIXME: erebar eunit
+}