summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-erlang
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-erlang')
-rw-r--r--dev-erlang/fast_xml/fast_xml-1.1.22.ebuild3
-rw-r--r--dev-erlang/fast_xml/fast_xml-1.1.34.ebuild1
-rw-r--r--dev-erlang/hamcrest/hamcrest-0.1.0_p20160709.ebuild3
-rw-r--r--dev-erlang/meck/meck-0.8.4.ebuild3
-rw-r--r--dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild3
-rw-r--r--dev-erlang/p1_oauth2/p1_oauth2-0.6.5.ebuild1
-rw-r--r--dev-erlang/protobuffs/protobuffs-0.9.0.ebuild3
-rw-r--r--dev-erlang/xmpp/xmpp-1.1.9.ebuild3
-rw-r--r--dev-erlang/xmpp/xmpp-1.2.5.ebuild3
9 files changed, 16 insertions, 7 deletions
diff --git a/dev-erlang/fast_xml/fast_xml-1.1.22.ebuild b/dev-erlang/fast_xml/fast_xml-1.1.22.ebuild
index 5cb4e92e0f91..1c1d52dae19d 100644
--- a/dev-erlang/fast_xml/fast_xml-1.1.22.ebuild
+++ b/dev-erlang/fast_xml/fast_xml-1.1.22.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,6 +14,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-erlang/p1_utils-1.0.7
>=dev-lang/erlang-17.1
diff --git a/dev-erlang/fast_xml/fast_xml-1.1.34.ebuild b/dev-erlang/fast_xml/fast_xml-1.1.34.ebuild
index 0b1c27f42890..d7a7ed543b5d 100644
--- a/dev-erlang/fast_xml/fast_xml-1.1.34.ebuild
+++ b/dev-erlang/fast_xml/fast_xml-1.1.34.ebuild
@@ -14,6 +14,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-erlang/p1_utils-1.0.13
>=dev-lang/erlang-17.1
diff --git a/dev-erlang/hamcrest/hamcrest-0.1.0_p20160709.ebuild b/dev-erlang/hamcrest/hamcrest-0.1.0_p20160709.ebuild
index aab42e80d660..6d92d2d1f421 100644
--- a/dev-erlang/hamcrest/hamcrest-0.1.0_p20160709.ebuild
+++ b/dev-erlang/hamcrest/hamcrest-0.1.0_p20160709.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,7 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
IUSE="test"
+RESTRICT="!test? ( test )"
CDEPEND=">=dev-lang/erlang-17.1"
DEPEND="${CDEPEND}
diff --git a/dev-erlang/meck/meck-0.8.4.ebuild b/dev-erlang/meck/meck-0.8.4.ebuild
index f712fb0cd778..f9d3518ff190 100644
--- a/dev-erlang/meck/meck-0.8.4.ebuild
+++ b/dev-erlang/meck/meck-0.8.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,6 +13,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
IUSE="test"
+RESTRICT="!test? ( test )"
CDEPEND=">=dev-lang/erlang-17.1"
DEPEND="${CDEPEND}
diff --git a/dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild b/dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild
index f151840da6e5..45a97620b3b4 100644
--- a/dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild
+++ b/dev-erlang/p1_oauth2/p1_oauth2-0.6.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,6 +14,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
IUSE="test"
+RESTRICT="!test? ( test )"
CDEPEND=">=dev-lang/erlang-17.1"
DEPEND="${CDEPEND}
diff --git a/dev-erlang/p1_oauth2/p1_oauth2-0.6.5.ebuild b/dev-erlang/p1_oauth2/p1_oauth2-0.6.5.ebuild
index ba3919e1090f..87f8db520570 100644
--- a/dev-erlang/p1_oauth2/p1_oauth2-0.6.5.ebuild
+++ b/dev-erlang/p1_oauth2/p1_oauth2-0.6.5.ebuild
@@ -14,6 +14,7 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
CDEPEND=">=dev-lang/erlang-17.1"
DEPEND="${CDEPEND}
diff --git a/dev-erlang/protobuffs/protobuffs-0.9.0.ebuild b/dev-erlang/protobuffs/protobuffs-0.9.0.ebuild
index ba33cf84dd63..b96a32127b39 100644
--- a/dev-erlang/protobuffs/protobuffs-0.9.0.ebuild
+++ b/dev-erlang/protobuffs/protobuffs-0.9.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,6 +17,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
IUSE="test"
+RESTRICT="!test? ( test )"
CDEPEND=">=dev-lang/erlang-17.1"
DEPEND="${CDEPEND}
diff --git a/dev-erlang/xmpp/xmpp-1.1.9.ebuild b/dev-erlang/xmpp/xmpp-1.1.9.ebuild
index 8b5fd3bf6a43..d72629575765 100644
--- a/dev-erlang/xmpp/xmpp-1.1.9.ebuild
+++ b/dev-erlang/xmpp/xmpp-1.1.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,6 +14,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm ~ia64 ppc ~sparc x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-erlang/fast_xml-1.1.22
>=dev-erlang/stringprep-1.0.8
diff --git a/dev-erlang/xmpp/xmpp-1.2.5.ebuild b/dev-erlang/xmpp/xmpp-1.2.5.ebuild
index 0a374c9a6bd5..1899c466a460 100644
--- a/dev-erlang/xmpp/xmpp-1.2.5.ebuild
+++ b/dev-erlang/xmpp/xmpp-1.2.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,6 +14,7 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-erlang/ezlib-1.0.4
>=dev-erlang/fast_tls-1.0.14