summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-06-23 20:05:21 +0200
committerHanno Böck <hanno@gentoo.org>2020-06-23 20:05:21 +0200
commit8d21e3aa4366432d35475172b5d10a008918b575 (patch)
tree527640a7371b321ec89c4a25a6d806cffc770598 /dev-erlang
parentnet-wireless/unifi: bump to 5.14.15, drop old (diff)
downloadgentoo-8d21e3aa4366432d35475172b5d10a008918b575.tar.gz
gentoo-8d21e3aa4366432d35475172b5d10a008918b575.tar.bz2
gentoo-8d21e3aa4366432d35475172b5d10a008918b575.zip
dev-erlang/jose: Bump.
Disable errors on compile warnings due to deprecations. Remove base64 dependency, no longer needed. Signed-off-by: Hanno Böck <hanno@gentoo.org> Closes: https://bugs.gentoo.org/723332 Package-Manager: Portage-2.3.102, Repoman-2.3.23
Diffstat (limited to 'dev-erlang')
-rw-r--r--dev-erlang/jose/Manifest1
-rw-r--r--dev-erlang/jose/jose-1.10.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-erlang/jose/Manifest b/dev-erlang/jose/Manifest
index 3ba506664455..c908bfb02590 100644
--- a/dev-erlang/jose/Manifest
+++ b/dev-erlang/jose/Manifest
@@ -1 +1,2 @@
+DIST erlang-jose-1.10.1.tar.gz 279187 BLAKE2B 18b606e5a2fd93b96a26b989a52235af08bd925eb610a9010b4ff930c1feb50bf8143456bd6b4743b53342948185eb5e4d4df760f774fc4bce1dc6a11fb2acf6 SHA512 2887a1d43e212516b32a0a690d5a94e6a797b4802b21fa0a51cc4830790f56625575db38af8fb1c0f4cf4694740c6149eb75989cfbd51867af69c1b23b7ba8ee
DIST erlang-jose-1.9.0.tar.gz 258407 BLAKE2B c6036e743b062cd18518537ffee03cc138f55f3973a2ab538410d362757747e2c8880a899326d494914068f36ffaf2bb902e83ba7899c3256d6cfc7b89f07156 SHA512 59f7123fe589c8e9bf0bab5a21089301d6b3a1c35316b9f530386bd0d9de8da8f5f956769ea6b1166c545a51d119668ed18db57e8adfa02e6f4327b01168db68
diff --git a/dev-erlang/jose/jose-1.10.1.ebuild b/dev-erlang/jose/jose-1.10.1.ebuild
new file mode 100644
index 000000000000..2edbf510886e
--- /dev/null
+++ b/dev-erlang/jose/jose-1.10.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit rebar
+
+DESCRIPTION="JSON Object Signing and Encryption (JOSE) for Erlang and Elixir"
+HOMEPAGE="https://github.com/potatosalad/erlang-jose"
+SRC_URI="https://github.com/potatosalad/erlang-jose/archive/${PV}.tar.gz
+ -> erlang-${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/erlang-19.0"
+RDEPEND="${DEPEND}"
+
+DOCS=( ALGORITHMS.md CHANGELOG.md README.md examples/KEY-GENERATION.md )
+
+# TODO: jose has test suite, but it require lots of dependencies. It may not be
+# TODO: urgent, but it would be nice to have those sooner or later.
+RESTRICT=test
+
+S="${WORKDIR}/erlang-${P}"
+
+src_prepare() {
+ # disable warnings_as_errors for erlang 23 compatibiltiy
+ # https://github.com/potatosalad/erlang-jose/issues/87
+ sed -i -e 's|warnings_as_errors||g' \
+ -e 's|debug_info,|debug_info|g' rebar.config
+ rebar_src_prepare
+}