summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/guichan
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/guichan')
-rw-r--r--dev-games/guichan/Manifest1
-rw-r--r--dev-games/guichan/files/guichan-0.8.2-as-needed.patch19
-rw-r--r--dev-games/guichan/files/guichan-0.8.2-automake-1.13.patch11
-rw-r--r--dev-games/guichan/guichan-0.8.2.ebuild45
-rw-r--r--dev-games/guichan/metadata.xml11
5 files changed, 87 insertions, 0 deletions
diff --git a/dev-games/guichan/Manifest b/dev-games/guichan/Manifest
new file mode 100644
index 000000000000..9f43971a13e9
--- /dev/null
+++ b/dev-games/guichan/Manifest
@@ -0,0 +1 @@
+DIST guichan-0.8.2.tar.gz 574662 SHA256 eedf206eae5201eaae027b133226d0793ab9a287bfd74c5f82c7681e3684eeab SHA512 b05b3da3c998399eadbaf3154de533038bb394919569c361c26245aa0e7072493b12d3556c94a2420622007525e19dcd76a27db06a76fb56ec96d50429a6ed98 WHIRLPOOL 3ad88b99e8be509a2e66e71999245904a96aa9a2f805adc208c3ff19b036335c334ce38ed90ee11fb1e19120e5a545530dda6de0cd81c011adadd89731e5da53
diff --git a/dev-games/guichan/files/guichan-0.8.2-as-needed.patch b/dev-games/guichan/files/guichan-0.8.2-as-needed.patch
new file mode 100644
index 000000000000..79eb563c0f8d
--- /dev/null
+++ b/dev-games/guichan/files/guichan-0.8.2-as-needed.patch
@@ -0,0 +1,19 @@
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -1,4 +1,4 @@
+-SUBDIRS = widgets @GUICHAN_EXTRADIRS@ hge openlayer contrib
++SUBDIRS = widgets . @GUICHAN_EXTRADIRS@ hge openlayer contrib
+
+ INCLUDES = -I$(top_srcdir)/include
+
+--- src/sdl/Makefile.am
++++ src/sdl/Makefile.am
+@@ -6,6 +6,8 @@
+
+ libguichan_sdl_la_LDFLAGS = -no-undefined -release $(LT_RELEASE) -version-info $(LT_CURRENT):$(LT_REVISION):$(LT_AGE)
+
++libguichan_sdl_la_LIBADD = -lSDL_image -L$(top_srcdir)/src -lguichan
++
+ libguichan_sdl_la_SOURCES = \
+ sdl.cpp \
+ sdlgraphics.cpp \
diff --git a/dev-games/guichan/files/guichan-0.8.2-automake-1.13.patch b/dev-games/guichan/files/guichan-0.8.2-automake-1.13.patch
new file mode 100644
index 000000000000..e2f46097b82a
--- /dev/null
+++ b/dev-games/guichan/files/guichan-0.8.2-automake-1.13.patch
@@ -0,0 +1,11 @@
+--- guichan-0.8.2/configure.in
++++ guichan-0.8.2/configure.in
+@@ -38,7 +38,7 @@
+ AC_SUBST(LT_AGE)
+
+ AM_INIT_AUTOMAKE(guichan, $GUICHAN_VERSION)
+-AM_CONFIG_HEADER([include/config.hpp])
++AC_CONFIG_HEADERS([include/config.hpp])
+
+ AC_CONFIG_SRCDIR([src/gui.cpp])
+
diff --git a/dev-games/guichan/guichan-0.8.2.ebuild b/dev-games/guichan/guichan-0.8.2.ebuild
new file mode 100644
index 000000000000..cac65a9990fe
--- /dev/null
+++ b/dev-games/guichan/guichan-0.8.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="a portable C++ GUI library designed for games using Allegro, SDL and/or OpenGL"
+HOMEPAGE="http://guichan.sourceforge.net/"
+SRC_URI="http://guichan.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="allegro opengl sdl static-libs"
+
+DEPEND="allegro? ( <media-libs/allegro-5 )
+ opengl? ( virtual/opengl )
+ sdl? (
+ media-libs/libsdl
+ media-libs/sdl-image
+ )"
+RDEPEND=${DEPEND}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-as-needed.patch \
+ "${FILESDIR}"/${P}-automake-1.13.patch
+ mv configure.in configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable allegro) \
+ $(use_enable opengl) \
+ $(use_enable sdl) \
+ $(use_enable sdl sdlimage) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}
diff --git a/dev-games/guichan/metadata.xml b/dev-games/guichan/metadata.xml
new file mode 100644
index 000000000000..9afc7ed48ba0
--- /dev/null
+++ b/dev-games/guichan/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <use>
+ <flag name="allegro">Build the Allegro frontend</flag>
+ </use>
+ <upstream>
+ <remote-id type="google-code">guichan</remote-id>
+ </upstream>
+</pkgmetadata>