summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/mygui/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/mygui/files')
-rw-r--r--dev-games/mygui/files/mygui-3.2.2-FHS.patch44
-rw-r--r--dev-games/mygui/files/mygui-3.2.2-build.patch61
-rw-r--r--dev-games/mygui/files/mygui-3.2.2-underlinking.patch20
3 files changed, 125 insertions, 0 deletions
diff --git a/dev-games/mygui/files/mygui-3.2.2-FHS.patch b/dev-games/mygui/files/mygui-3.2.2-FHS.patch
new file mode 100644
index 000000000000..14d21626ff7b
--- /dev/null
+++ b/dev-games/mygui/files/mygui-3.2.2-FHS.patch
@@ -0,0 +1,44 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sat Oct 27 22:39:31 UTC 2012
+Subject: FHS
+
+paths hardcoded until upstream fixed the logic
+
+--- mygui-MyGUI3.2.2.orig/CMake/InstallResources.cmake
++++ mygui-MyGUI3.2.2/CMake/InstallResources.cmake
+@@ -24,7 +24,7 @@
+ else ()
+ install(FILES
+ ${MYGUI_BINARY_DIR}/bin/${FILENAME}
+- DESTINATION "bin"
++ DESTINATION "/etc/MYGUI"
+ )
+ endif ()
+ endfunction(install_file)
+@@ -53,7 +53,7 @@
+ if (WIN32)
+ set(MYGUI_MEDIA_DIR "../../Media")
+ elseif (UNIX)
+- set(MYGUI_MEDIA_DIR "../share/MYGUI/Media")
++ set(MYGUI_MEDIA_DIR "${CMAKE_INSTALL_PREFIX}/share/MYGUI/Media")
+ else ()
+ set(MYGUI_MEDIA_DIR "../../Media")
+ endif ()
+--- mygui-MyGUI3.2.2.orig/Common/Base/Ogre/BaseManager.cpp
++++ mygui-MyGUI3.2.2/Common/Base/Ogre/BaseManager.cpp
+@@ -49,13 +49,13 @@
+ mWindow(nullptr),
+ mExit(false),
+ mPluginCfgName("plugins.cfg"),
+- mResourceXMLName("resources.xml"),
++ mResourceXMLName("/etc/MYGUI/resources.xml"),
+ mResourceFileName("MyGUI_Core.xml")
+ {
+ #if MYGUI_PLATFORM == MYGUI_PLATFORM_APPLE
+ mResourcePath = macBundlePath() + "/Contents/Resources/";
+ #else
+- mResourcePath = "";
++ mResourcePath = "/etc/MYGUI/";
+ #endif
+ }
+
diff --git a/dev-games/mygui/files/mygui-3.2.2-build.patch b/dev-games/mygui/files/mygui-3.2.2-build.patch
new file mode 100644
index 000000000000..a16b27c285b7
--- /dev/null
+++ b/dev-games/mygui/files/mygui-3.2.2-build.patch
@@ -0,0 +1,61 @@
+diff -ru mygui-MyGUI3.2.2.orig/CMake/ConfigureBuild.cmake mygui-MyGUI3.2.2/CMake/ConfigureBuild.cmake
+--- mygui-MyGUI3.2.2.orig/CMake/ConfigureBuild.cmake 2015-01-26 10:32:35.000000000 -0500
++++ mygui-MyGUI3.2.2/CMake/ConfigureBuild.cmake 2015-03-14 01:09:40.743621643 -0400
+@@ -4,6 +4,8 @@
+ # also prepare package files for pkg-config and CMake.
+ #######################################################################
+
++include(GNUInstallDirs)
++
+ # should we build static libs?
+ if (MYGUI_STATIC)
+ set(MYGUI_LIB_TYPE STATIC)
+@@ -47,7 +49,7 @@
+ else ()
+ configure_file(${MYGUI_TEMPLATES_DIR}/MYGUI.pc.in ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc @ONLY)
+ endif ()
+- install(FILES ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc DESTINATION lib/pkgconfig)
++ install(FILES ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+
+ # configure additional packages
+
+diff -ru mygui-MyGUI3.2.2.orig/CMake/Utils/MyGUIConfigTargets.cmake mygui-MyGUI3.2.2/CMake/Utils/MyGUIConfigTargets.cmake
+--- mygui-MyGUI3.2.2.orig/CMake/Utils/MyGUIConfigTargets.cmake 2015-01-26 10:32:35.000000000 -0500
++++ mygui-MyGUI3.2.2/CMake/Utils/MyGUIConfigTargets.cmake 2015-03-14 01:08:44.905791784 -0400
+@@ -1,6 +1,8 @@
+ # Configure settings and install targets
+ # FIXME: Copypasted from Ogre and need lots of changes
+
++include(GNUInstallDirs)
++
+ if (WIN32)
+ set(MYGUI_RELEASE_PATH "/Release")
+ set(MYGUI_RELWDBG_PATH "/RelWithDebInfo")
+@@ -60,6 +62,12 @@
+ # install targets according to current build type
+ function(mygui_install_target TARGETNAME SUFFIX)
+ install(TARGETS ${TARGETNAME}
++ RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}" CONFIGURATIONS Gentoo ""
++ LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}" CONFIGURATIONS Gentoo ""
++ ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}" CONFIGURATIONS Gentoo ""
++ FRAMEWORK DESTINATION "${MYGUI_FRAMEWORK_PATH}" CONFIGURATIONS Gentoo ""
++ )
++ install(TARGETS ${TARGETNAME}
+ RUNTIME DESTINATION "bin${MYGUI_RELEASE_PATH}" CONFIGURATIONS Release None ""
+ LIBRARY DESTINATION "lib${MYGUI_LIB_RELEASE_PATH}${SUFFIX}" CONFIGURATIONS Release None ""
+ ARCHIVE DESTINATION "lib${MYGUI_LIB_RELEASE_PATH}${SUFFIX}" CONFIGURATIONS Release None ""
+@@ -171,7 +179,13 @@
+ endif ()
+ add_executable(${PROJECTNAME} ${MYGUI_EXEC_TYPE} ${HEADER_FILES} ${SOURCE_FILES})
+ endif ()
+- set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER})
++
++ # rename demo target^M
++ if (${SOLUTIONFOLDER} STREQUAL "Demos")
++ set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER} OUTPUT_NAME MYGUI-${PROJECTNAME})
++ else()
++ set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER})
++ endif()
+
+ add_dependencies(${PROJECTNAME} MyGUIEngine Common)
+
diff --git a/dev-games/mygui/files/mygui-3.2.2-underlinking.patch b/dev-games/mygui/files/mygui-3.2.2-underlinking.patch
new file mode 100644
index 000000000000..2d1026856f03
--- /dev/null
+++ b/dev-games/mygui/files/mygui-3.2.2-underlinking.patch
@@ -0,0 +1,20 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri Jun 15 10:42:42 UTC 2012
+Subject: build system
+
+fix underlinking
+
+--- MyGUIEngine/CMakeLists.txt
++++ MyGUIEngine/CMakeLists.txt
+@@ -48,7 +48,10 @@
+ if (MYGUI_USE_FREETYPE)
+ target_link_libraries(${PROJECTNAME}
+ ${FREETYPE_LIBRARIES}
+- )
++ dl)
++else()
++ target_link_libraries(${PROJECTNAME}
++ dl)
+ endif()
+
+ # platform specific dependencies