summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-10-11 11:18:04 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-10-11 11:18:10 +0100
commitf838d5aa1b2dd5952c018c125ed6b72bf71a70fe (patch)
tree0c8260691cff861ec4e0060d6b01c1e8c10e5a4b /dev-games/mygui
parentdev-perl/Data-Validate-IP: Keyword ~arm64 re bug #747604 (diff)
downloadgentoo-f838d5aa1b2dd5952c018c125ed6b72bf71a70fe.tar.gz
gentoo-f838d5aa1b2dd5952c018c125ed6b72bf71a70fe.tar.bz2
gentoo-f838d5aa1b2dd5952c018c125ed6b72bf71a70fe.zip
dev-games/mygui: fix build on c++17 compiler (gcc-11)
Reported-by: lekto@o2.pl Closes: https://bugs.gentoo.org/732778 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-games/mygui')
-rw-r--r--dev-games/mygui/files/mygui-3.2.2-c++17.patch27
-rw-r--r--dev-games/mygui/mygui-3.2.2.ebuild3
2 files changed, 29 insertions, 1 deletions
diff --git a/dev-games/mygui/files/mygui-3.2.2-c++17.patch b/dev-games/mygui/files/mygui-3.2.2-c++17.patch
new file mode 100644
index 000000000000..1cdf7babeb12
--- /dev/null
+++ b/dev-games/mygui/files/mygui-3.2.2-c++17.patch
@@ -0,0 +1,27 @@
+https://github.com/MyGUI/mygui/commit/ced30dac10082ff9593a2c971d26b3aebce6b2be.patch
+https://bugs.gentoo.org/732778
+
+Part of:
+
+From ced30dac10082ff9593a2c971d26b3aebce6b2be Mon Sep 17 00:00:00 2001
+From: George Evmenov <george.evmenov@geocv.com>
+Date: Fri, 26 Jun 2015 12:25:26 +0300
+Subject: [PATCH] do not use nullptr define
+
+--- a/MyGUIEngine/include/MyGUI_Prerequest.h
++++ b/MyGUIEngine/include/MyGUI_Prerequest.h
+@@ -19,13 +19,7 @@
+ #define MYGUI_DEFINE_VERSION(major, minor, patch) ((major << 16) | (minor << 8) | patch)
+
+ #ifndef MYGUI_DONT_REPLACE_NULLPTR
+-# if MYGUI_COMPILER == MYGUI_COMPILER_MSVC
+-# ifndef _MANAGED
+-# ifndef _NATIVE_NULLPTR_SUPPORTED
+-# define nullptr 0
+-# endif
+-# endif
+-# else
++# if __cplusplus < 201103L && !defined(_NATIVE_NULLPTR_SUPPORTED)
+ # define nullptr 0
+ # endif
+ #endif
diff --git a/dev-games/mygui/mygui-3.2.2.ebuild b/dev-games/mygui/mygui-3.2.2.ebuild
index ac582627a70d..dc3766716faf 100644
--- a/dev-games/mygui/mygui-3.2.2.ebuild
+++ b/dev-games/mygui/mygui-3.2.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -41,6 +41,7 @@ PATCHES=(
"${FILESDIR}"/${P}-underlinking.patch
"${FILESDIR}"/${P}-build.patch
"${FILESDIR}"/${P}-FHS.patch
+ "${FILESDIR}"/${P}-c++17.patch
)
pkg_setup() {