summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/physfs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/physfs')
-rw-r--r--dev-games/physfs/Manifest1
-rw-r--r--dev-games/physfs/metadata.xml30
-rw-r--r--dev-games/physfs/physfs-2.0.3-r1.ebuild57
3 files changed, 88 insertions, 0 deletions
diff --git a/dev-games/physfs/Manifest b/dev-games/physfs/Manifest
new file mode 100644
index 000000000000..bdb7b23eccf6
--- /dev/null
+++ b/dev-games/physfs/Manifest
@@ -0,0 +1 @@
+DIST physfs-2.0.3.tar.bz2 560628 SHA256 ca862097c0fb451f2cacd286194d071289342c107b6fe69079c079883ff66b69 SHA512 47eff0c81b8dc3bb526766b0a8ad2437d2951867880116d6e6e8f2ec1490e263541fb741867fed6517cc3fa8a9c5651b36e3e02a499f19cfdc5c7261c9707e80 WHIRLPOOL 30362f92d5702842142c08c3183a384876a03e9e3e400364b0fa59c99ffee994667c1ad08fe633ef146e98301789a980a3419f60a18b24b9c341bb74144ccc73
diff --git a/dev-games/physfs/metadata.xml b/dev-games/physfs/metadata.xml
new file mode 100644
index 000000000000..e67532100d47
--- /dev/null
+++ b/dev-games/physfs/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<longdescription>
+PhysicsFS is a library to provide abstract access to various archives. It is
+intended for use in video games, and the design was somewhat inspired by Quake 3's
+file subsystem. The programmer defines a "write directory" on the physical
+filesystem. No file writing done through the PhysicsFS API can leave that write
+directory, for security. For example, an embedded scripting language cannot write
+outside of this path if it uses PhysFS for all of its I/O, which means that
+untrusted scripts can run more safely. Symbolic links can be disabled as well, for
+added safety. For file reading, the programmer lists directories and archives that
+form a "search path". Once the search path is defined, it becomes a single,
+transparent hierarchical filesystem. This makes for easy access to ZIP files in the
+same way as you access a file directly on the disk, and it makes it easy to ship a
+new archive that will override a previous archive on a per-file basis. Finally,
+PhysicsFS gives you platform-abstracted means to determine if CD-ROMs are available,
+the user's home directory, where in the real filesystem your program is running,
+etc.
+</longdescription>
+<use>
+<flag name="grp">Enable Build Engine GRP archive support</flag>
+<flag name="hog">Enable Descent I/II HOG archive support</flag>
+<flag name="mvl">Enable Descent I/II MVL archive support</flag>
+<flag name="wad">Enable Doom WAD archive support</flag>
+<flag name="qpak">Enable Quake I/II QPAK archive support</flag>
+<flag name="zip">Enable ZIP archive support</flag>
+</use>
+</pkgmetadata>
diff --git a/dev-games/physfs/physfs-2.0.3-r1.ebuild b/dev-games/physfs/physfs-2.0.3-r1.ebuild
new file mode 100644
index 000000000000..e740a069bcff
--- /dev/null
+++ b/dev-games/physfs/physfs-2.0.3-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-multilib
+
+DESCRIPTION="Abstraction layer for filesystem and archive access"
+HOMEPAGE="http://icculus.org/physfs/"
+SRC_URI="http://icculus.org/physfs/downloads/${P}.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="doc grp hog mvl qpak static-libs wad +zip"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ sed -i -e 's:-Werror::' CMakeLists.txt || die
+ # make sure these libs aren't used
+ rm -rf lzma zlib*
+}
+
+src_configure() {
+ local mycmakeargs="
+ -DPHYSFS_ARCHIVE_7Z=OFF
+ -DPHYSFS_BUILD_SHARED=ON
+ -DPHYSFS_BUILD_TEST=OFF
+ -DPHYSFS_BUILD_WX_TEST=OFF
+ -DPHYSFS_INTERNAL_ZLIB=OFF
+ $(cmake-utils_use static-libs PHYSFS_BUILD_STATIC)
+ $(cmake-utils_use grp PHYSFS_ARCHIVE_GRP)
+ $(cmake-utils_use hog PHYSFS_ARCHIVE_HOG)
+ $(cmake-utils_use mvl PHYSFS_ARCHIVE_MVL)
+ $(cmake-utils_use wad PHYSFS_ARCHIVE_WAD)
+ $(cmake-utils_use qpak PHYSFS_ARCHIVE_QPAK)
+ $(cmake-utils_use zip PHYSFS_ARCHIVE_ZIP)"
+
+ cmake-multilib_src_configure
+}
+
+src_compile() {
+ cmake-multilib_src_compile
+
+ if multilib_is_native_abi && use doc ; then
+ doxygen || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ local DOCS="CHANGELOG.txt CREDITS.txt TODO.txt"
+ local HTML_DOCS=$(use doc && echo docs/html/*)
+
+ cmake-multilib_src_install
+}