summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-13 00:39:16 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-13 02:17:44 +0200
commit76aca1152d93c82f0e6bf01996e6b1957915468f (patch)
tree0c3decc002f9f0fe03636f518adb59450487ca8b /dev-games/physfs
parentdev-libs/redland: Drop 1.0.17-r1 (diff)
downloadgentoo-76aca1152d93c82f0e6bf01996e6b1957915468f.tar.gz
gentoo-76aca1152d93c82f0e6bf01996e6b1957915468f.tar.bz2
gentoo-76aca1152d93c82f0e6bf01996e6b1957915468f.zip
dev-games/physfs: Fix build with USE=doc
Closes: https://bugs.gentoo.org/682080 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-games/physfs')
-rw-r--r--dev-games/physfs/physfs-3.0.2.ebuild10
-rw-r--r--dev-games/physfs/physfs-9999.ebuild10
2 files changed, 8 insertions, 12 deletions
diff --git a/dev-games/physfs/physfs-3.0.2.ebuild b/dev-games/physfs/physfs-3.0.2.ebuild
index 683b49ac714d..0880049c9f1c 100644
--- a/dev-games/physfs/physfs-3.0.2.ebuild
+++ b/dev-games/physfs/physfs-3.0.2.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit cmake-multilib
DESCRIPTION="Abstraction layer for filesystem and archive access"
@@ -47,10 +48,7 @@ multilib_src_compile() {
multilib_is_native_abi && use doc && cmake-utils_src_compile docs
}
-multilib_src_install_all() {
- einstalldocs
- if use doc ; then
- docinto html
- dodoc -r "${CMAKE_BUILD_DIR}"/docs/html/*
- fi
+multilib_src_install() {
+ multilib_is_native_abi && use doc && local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
+ cmake-utils_src_install
}
diff --git a/dev-games/physfs/physfs-9999.ebuild b/dev-games/physfs/physfs-9999.ebuild
index 683b49ac714d..0880049c9f1c 100644
--- a/dev-games/physfs/physfs-9999.ebuild
+++ b/dev-games/physfs/physfs-9999.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit cmake-multilib
DESCRIPTION="Abstraction layer for filesystem and archive access"
@@ -47,10 +48,7 @@ multilib_src_compile() {
multilib_is_native_abi && use doc && cmake-utils_src_compile docs
}
-multilib_src_install_all() {
- einstalldocs
- if use doc ; then
- docinto html
- dodoc -r "${CMAKE_BUILD_DIR}"/docs/html/*
- fi
+multilib_src_install() {
+ multilib_is_native_abi && use doc && local HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
+ cmake-utils_src_install
}