summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-03 20:34:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-04 10:37:21 +0100
commit7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af (patch)
treee0665a5ce5c6e08888f9f76d783748602c5b92c8 /dev-games/physfs
parentwww-client/epiphany: bump to 3.32.6 (diff)
downloadgentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.gz
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.tar.bz2
gentoo-7b39c6e5c4db51c5f45bb47a3e38d0da17ef95af.zip
*/*: Switch games proj to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-games/physfs')
-rw-r--r--dev-games/physfs/physfs-3.0.2.ebuild7
-rw-r--r--dev-games/physfs/physfs-9999.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/dev-games/physfs/physfs-3.0.2.ebuild b/dev-games/physfs/physfs-3.0.2.ebuild
index 37c14d9804c5..774fa791efd5 100644
--- a/dev-games/physfs/physfs-3.0.2.ebuild
+++ b/dev-games/physfs/physfs-3.0.2.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="Abstraction layer for filesystem and archive access"
@@ -40,14 +41,14 @@ multilib_src_configure() {
-DPHYSFS_ARCHIVE_QPAK="$(usex qpak)"
-DPHYSFS_ARCHIVE_ZIP="$(usex zip)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if multilib_is_native_abi && use doc; then
- cmake-utils_src_compile docs
+ cmake_src_compile docs
HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
fi
}
diff --git a/dev-games/physfs/physfs-9999.ebuild b/dev-games/physfs/physfs-9999.ebuild
index dbaa669aacc9..9490039a10a7 100644
--- a/dev-games/physfs/physfs-9999.ebuild
+++ b/dev-games/physfs/physfs-9999.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+CMAKE_ECLASS=cmake
inherit cmake-multilib
DESCRIPTION="Abstraction layer for filesystem and archive access"
@@ -40,14 +41,14 @@ multilib_src_configure() {
-DPHYSFS_ARCHIVE_QPAK="$(usex qpak)"
-DPHYSFS_ARCHIVE_ZIP="$(usex zip)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
multilib_src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if multilib_is_native_abi && use doc; then
- cmake-utils_src_compile docs
+ cmake_src_compile docs
HTML_DOCS=( "${BUILD_DIR}"/docs/html/. )
fi
}