summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2018-06-04 03:39:02 +0200
committerMaciej Mrozowski <reavertm@gentoo.org>2018-06-04 03:41:09 +0200
commitc4e6a000a88ee161f778d51640e3013f0be45a8e (patch)
tree3c72898b11c6ac6d5bbc4f81d8ca3951e2d1cdaa /dev-games/simgear/simgear-2018.2.1.ebuild
parentapp-emulation/dlx: drop DEPEND as nothing is there (diff)
downloadgentoo-c4e6a000a88ee161f778d51640e3013f0be45a8e.tar.gz
gentoo-c4e6a000a88ee161f778d51640e3013f0be45a8e.tar.bz2
gentoo-c4e6a000a88ee161f778d51640e3013f0be45a8e.zip
games-simulation/flightgear: version bump 2018.2.1
Diffstat (limited to 'dev-games/simgear/simgear-2018.2.1.ebuild')
-rw-r--r--dev-games/simgear/simgear-2018.2.1.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-games/simgear/simgear-2018.2.1.ebuild b/dev-games/simgear/simgear-2018.2.1.ebuild
new file mode 100644
index 000000000000..c8c3453c3016
--- /dev/null
+++ b/dev-games/simgear/simgear-2018.2.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils toolchain-funcs
+
+DESCRIPTION="Development library for simulation games"
+HOMEPAGE="http://www.simgear.org/"
+SRC_URI="mirror://sourceforge/flightgear/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+dns debug gdal openmp subversion test"
+
+COMMON_DEPEND="
+ dev-libs/expat
+ >=dev-games/openscenegraph-3.2.0
+ media-libs/openal
+ net-misc/curl
+ sys-libs/zlib
+ virtual/opengl
+ dns? ( net-libs/udns )
+ gdal? ( sci-libs/gdal )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.44
+"
+RDEPEND="${COMMON_DEPEND}
+ subversion? ( dev-vcs/subversion )
+"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DNS=$(usex dns)
+ -DENABLE_GDAL=$(usex gdal)
+ -DENABLE_OPENMP=$(usex openmp)
+ -DENABLE_PKGUTIL=ON
+ -DENABLE_RTI=OFF
+ -DENABLE_SIMD=ON
+ -DENABLE_SOUND=ON
+ -DENABLE_TESTS=$(usex test)
+ -DSIMGEAR_HEADLESS=OFF
+ -DSIMGEAR_SHARED=ON
+ -DSYSTEM_EXPAT=ON
+ -DSYSTEM_UDNS=ON
+ -DUSE_AEONWAVE=OFF
+ -DOSG_FSTREAM_EXPORT_FIXED=OFF # TODO perhaps track it
+ )
+ cmake-utils_src_configure
+}