summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-05-25 19:56:04 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-25 22:54:37 +0200
commit15251ba9c43dbb9661083f2c65000c9219006d3f (patch)
tree6c7be0bbc5089b85e3b162fa6ef3f845e3725ea5 /dev-games
parentdev-libs/quazip: 0.8 version bump (diff)
downloadgentoo-15251ba9c43dbb9661083f2c65000c9219006d3f.tar.gz
gentoo-15251ba9c43dbb9661083f2c65000c9219006d3f.tar.bz2
gentoo-15251ba9c43dbb9661083f2c65000c9219006d3f.zip
dev-games/simgear: Fix build with >=boost-1.69
Closes: https://bugs.gentoo.org/684026 Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/simgear/files/simgear-2018.3.2-boost-1.69.patch24
-rw-r--r--dev-games/simgear/simgear-2018.3.2.ebuild2
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-games/simgear/files/simgear-2018.3.2-boost-1.69.patch b/dev-games/simgear/files/simgear-2018.3.2-boost-1.69.patch
new file mode 100644
index 000000000000..2372c8c58adf
--- /dev/null
+++ b/dev-games/simgear/files/simgear-2018.3.2-boost-1.69.patch
@@ -0,0 +1,24 @@
+From c1ac1fb93dace81b2a60f9d1f5d6d20298c8b9bb Mon Sep 17 00:00:00 2001
+From: Fabrice Bellet <fabrice@bellet.info>
+Date: Fri, 1 Feb 2019 09:29:40 +0100
+Subject: [PATCH] fix for boost 1.69
+
+---
+ simgear/nasal/cppbind/NasalHash.hxx | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/simgear/nasal/cppbind/NasalHash.hxx b/simgear/nasal/cppbind/NasalHash.hxx
+index aac672fd..2ee7d044 100644
+--- a/simgear/nasal/cppbind/NasalHash.hxx
++++ b/simgear/nasal/cppbind/NasalHash.hxx
+@@ -23,6 +23,7 @@
+ #include "to_nasal.hxx"
+
+ #include <simgear/structure/map.hxx>
++#include <boost/core/enable_if.hpp>
+ #include <boost/iterator/iterator_facade.hpp>
+
+ namespace nasal
+--
+2.20.1
+
diff --git a/dev-games/simgear/simgear-2018.3.2.ebuild b/dev-games/simgear/simgear-2018.3.2.ebuild
index a65b51665aac..ead30a3c496f 100644
--- a/dev-games/simgear/simgear-2018.3.2.ebuild
+++ b/dev-games/simgear/simgear-2018.3.2.ebuild
@@ -31,6 +31,8 @@ RDEPEND="${COMMON_DEPEND}
subversion? ( dev-vcs/subversion )
"
+PATCHES=( "${FILESDIR}/${P}-boost-1.69.patch" )
+
pkg_pretend() {
[[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}