summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2019-03-18 00:35:32 +0100
committerMaciej Mrozowski <reavertm@gentoo.org>2019-03-18 00:40:27 +0100
commit76fbe622c5c4c49cfebfa2d85e42c016ee0366b6 (patch)
treec13d386620e1e27117ab3b66d2770a3bcb5ab3a1 /dev-games
parentnet-misc/putty: Version 0.71 (diff)
downloadgentoo-76fbe622c5c4c49cfebfa2d85e42c016ee0366b6.tar.gz
gentoo-76fbe622c5c4c49cfebfa2d85e42c016ee0366b6.tar.bz2
gentoo-76fbe622c5c4c49cfebfa2d85e42c016ee0366b6.zip
games-simulation/flightgear: Version bump 2018.3.2
Signed-off-by: Maciej Mrozowski <reavertm@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/simgear/Manifest1
-rw-r--r--dev-games/simgear/simgear-2018.3.2.ebuild66
-rw-r--r--dev-games/simgear/simgear-9999.ebuild14
3 files changed, 77 insertions, 4 deletions
diff --git a/dev-games/simgear/Manifest b/dev-games/simgear/Manifest
index c17226fec253..ae0736f5723e 100644
--- a/dev-games/simgear/Manifest
+++ b/dev-games/simgear/Manifest
@@ -1 +1,2 @@
DIST simgear-2018.3.1.tar.bz2 1330322 BLAKE2B 5b350ddce726d8ea15c4a1a64a28b9e4307647378c52989231daa7b4a0e53730dc754c239660d0f5ec33189ece6629448b37f61ca7578c21c3aa4147d4565a26 SHA512 673ee76e9f4f9c9adb25a2523bad5b70a079d821391cb8fc9f9e651ad6c195356ac9a8ba18a65df365dc66990406de287099fb249ca23eefc111ebba884f7289
+DIST simgear-2018.3.2.tar.bz2 1329982 BLAKE2B cc4ee90e0a76db5212ca3bb8f422376d9fd91c261c4aaee1aa0c2dc7438ed589866bdde009fd44c727ae87d7365d4aea67da0cfd32ff26d47e81eb9c027ddf0b SHA512 3f60df34f22ea84bdb3e0aa0e2c0b73b2fddf15d17ea985aee254bf4c269b7447976629a7e4b022c460c7c406940d0b2669b723c6b899499d064cfe91546f0ba
diff --git a/dev-games/simgear/simgear-2018.3.2.ebuild b/dev-games/simgear/simgear-2018.3.2.ebuild
new file mode 100644
index 000000000000..a65b51665aac
--- /dev/null
+++ b/dev-games/simgear/simgear-2018.3.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils toolchain-funcs flag-o-matic
+
+DESCRIPTION="Development library for simulation games"
+HOMEPAGE="http://www.simgear.org/"
+SRC_URI="mirror://sourceforge/flightgear/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="cpu_flags_x86_sse2 +dns debug gdal openmp subversion test"
+
+COMMON_DEPEND="
+ dev-libs/expat
+ <dev-games/openscenegraph-3.5.6:=
+ media-libs/openal
+ net-misc/curl
+ sys-libs/zlib
+ virtual/opengl
+ dns? ( net-libs/udns )
+ gdal? ( sci-libs/gdal )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-libs/boost-1.44
+"
+RDEPEND="${COMMON_DEPEND}
+ subversion? ( dev-vcs/subversion )
+"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DNS=$(usex dns)
+ -DENABLE_GDAL=$(usex gdal)
+ -DENABLE_OPENMP=$(usex openmp)
+ -DENABLE_PKGUTIL=ON
+ -DENABLE_RTI=OFF
+ -DENABLE_SIMD=OFF # see CPU_FLAGS
+ -DENABLE_SIMD_CODE=OFF
+ -DENABLE_SOUND=ON
+ -DENABLE_TESTS=$(usex test)
+ -DSIMGEAR_HEADLESS=OFF
+ -DSIMGEAR_SHARED=ON
+ -DSYSTEM_EXPAT=ON
+ -DSYSTEM_UDNS=ON
+ -DUSE_AEONWAVE=OFF
+ -DOSG_FSTREAM_EXPORT_FIXED=OFF # TODO perhaps track it
+ )
+
+ if use cpu_flags_x86_sse2; then
+ append-flags -msse2 -mfpmath=sse -ftree-vectorize -ftree-slp-vectorize
+ fi
+
+ cmake-utils_src_configure
+}
diff --git a/dev-games/simgear/simgear-9999.ebuild b/dev-games/simgear/simgear-9999.ebuild
index 10462f88d9fc..4ef9fc550b61 100644
--- a/dev-games/simgear/simgear-9999.ebuild
+++ b/dev-games/simgear/simgear-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils cmake-utils toolchain-funcs git-r3
+inherit eutils cmake-utils toolchain-funcs flag-o-matic git-r3
DESCRIPTION="Development library for simulation games"
HOMEPAGE="http://www.simgear.org/"
@@ -14,7 +14,7 @@ EGIT_BRANCH="next"
LICENSE="GPL-2"
KEYWORDS=""
SLOT="0"
-IUSE="+dns debug gdal openmp subversion test"
+IUSE="cpu_flags_x86_sse2 +dns debug gdal openmp subversion test"
COMMON_DEPEND="
dev-libs/expat
@@ -48,7 +48,8 @@ src_configure() {
-DENABLE_OPENMP=$(usex openmp)
-DENABLE_PKGUTIL=ON
-DENABLE_RTI=OFF
- -DENABLE_SIMD=ON
+ -DENABLE_SIMD=OFF # see CPU_FLAGS
+ -DENABLE_SIMD_CODE=OFF
-DENABLE_SOUND=ON
-DENABLE_TESTS=$(usex test)
-DSIMGEAR_HEADLESS=OFF
@@ -58,5 +59,10 @@ src_configure() {
-DUSE_AEONWAVE=OFF
-DOSG_FSTREAM_EXPORT_FIXED=OFF # TODO perhaps track it
)
+
+ if use cpu_flags_x86_sse2; then
+ append-flags -msse2 -mfpmath=sse -ftree-vectorize -ftree-slp-vectorize
+ fi
+
cmake-utils_src_configure
}