summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2020-07-07 21:44:14 +0200
committerJames Le Cuirot <chewi@gentoo.org>2020-07-26 21:22:56 +0100
commit84cbacce2ed094b6f685dbba3c1380dbdaa6281c (patch)
treee0c3699b3bf2c957c0d96bf614dcf0406e6c76ed /dev-games
parentnet-im/telegram-desktop: bump to 2.2.0 (diff)
downloadgentoo-84cbacce2ed094b6f685dbba3c1380dbdaa6281c.tar.gz
gentoo-84cbacce2ed094b6f685dbba3c1380dbdaa6281c.tar.bz2
gentoo-84cbacce2ed094b6f685dbba3c1380dbdaa6281c.zip
dev-games/flatzebra: EAPI7, fix LICENSE, cleanup
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16628 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/flatzebra/flatzebra-0.1.6-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-games/flatzebra/flatzebra-0.1.6-r1.ebuild b/dev-games/flatzebra/flatzebra-0.1.6-r1.ebuild
new file mode 100644
index 000000000000..ab4dc154a023
--- /dev/null
+++ b/dev-games/flatzebra/flatzebra-0.1.6-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Generic game engine for 2D double-buffering animation"
+HOMEPAGE="https://perso.b2b2c.ca/~sarrazip/dev/batrachians.html"
+SRC_URI="https://perso.b2b2c.ca/~sarrazip/dev/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="media-libs/libsdl[video]
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ sed -i \
+ -e '/^doc_DATA =/s/^/NOTHANKS/' \
+ Makefile.in || die
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ find "${ED}" -type f -name '*.la' -delete || die
+ fi
+}