summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-go/go-spew
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-go/go-spew')
-rw-r--r--dev-go/go-spew/Manifest1
-rw-r--r--dev-go/go-spew/go-spew-0_pre20150619.ebuild59
-rw-r--r--dev-go/go-spew/go-spew-9999.ebuild26
-rw-r--r--dev-go/go-spew/metadata.xml10
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-go/go-spew/Manifest b/dev-go/go-spew/Manifest
new file mode 100644
index 000000000000..2639fedbfc79
--- /dev/null
+++ b/dev-go/go-spew/Manifest
@@ -0,0 +1 @@
+DIST go-spew-0_pre20150619.tar.gz 41714 SHA256 e064d12586e3685d32eb0bd125b9e4c19291fdcc07bd21e067593cbc81525e1c SHA512 84ec5cbf26b59d6380d09b4e053427d8c8b93555e43de4a95d373b7fb1edc647f0c950caaacf451c03872171d138e717b1fa9a1ea0f14208a9a5197bd83ce037 WHIRLPOOL 31f9823776b77317b26a256ba3615cf7aeae4c3d46f54b2840ed742770369a15bfa8a972252229eaa907e16c40a18573e1df748a99c86bf244ed4b43d86db409
diff --git a/dev-go/go-spew/go-spew-0_pre20150619.ebuild b/dev-go/go-spew/go-spew-0_pre20150619.ebuild
new file mode 100644
index 000000000000..9b9367f2b3da
--- /dev/null
+++ b/dev-go/go-spew/go-spew-0_pre20150619.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_SRC=github.com/davecgh/${PN}
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="2df174808ee097f90d259e432cc04442cf60be21"
+ SRC_URI="https://${EGO_SRC}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+fi
+inherit golang-build
+
+DESCRIPTION="Implements a deep pretty printer for Go data structures to aid in debugging"
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="ISC"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+if [[ ${PV} != *9999* ]]; then
+src_unpack() {
+ local f
+
+ for f in ${A}
+ do
+ case "${f}" in
+ *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
+ local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
+
+ debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
+
+ # XXX: check whether the directory structure inside is
+ # fine? i.e. if the tarball has actually a parent dir.
+ mkdir -p "${destdir}" || die
+ tar -C "${destdir}" -x --strip-components 1 \
+ -f "${DISTDIR}/${f}" || die
+ ;;
+ *)
+ debug-print "${FUNCNAME}: falling back to unpack for ${f}"
+
+ # fall back to the default method
+ unpack "${f}"
+ ;;
+ esac
+ done
+}
+fi
+
+src_install() {
+ rm -rf src/${EGO_SRC}/.git* || die
+ golang-build_src_install
+}
diff --git a/dev-go/go-spew/go-spew-9999.ebuild b/dev-go/go-spew/go-spew-9999.ebuild
new file mode 100644
index 000000000000..26f65ba85137
--- /dev/null
+++ b/dev-go/go-spew/go-spew-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_SRC=github.com/davecgh/${PN}
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="2df174808ee097f90d259e432cc04442cf60be21"
+ SRC_URI="https://${EGO_SRC}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Implements a deep pretty printer for Go data structures to aid in debugging"
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="ISC"
+SLOT="0/${PV}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
diff --git a/dev-go/go-spew/metadata.xml b/dev-go/go-spew/metadata.xml
new file mode 100644
index 000000000000..d2c2e9307d05
--- /dev/null
+++ b/dev-go/go-spew/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">davecgh/go-spew</remote-id>
+ </upstream>
+</pkgmetadata>