summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2018-08-18 17:56:23 -0700
committerZac Medico <zmedico@gentoo.org>2018-08-18 23:37:58 -0700
commit0a04bb4a4ba5f2a56361f4fb40fcbf70e531feb6 (patch)
tree59033147cb485ddefcffe93ceb458d9c17d4da71 /dev-go/go-sys/go-sys-0_pre20180816.ebuild
parentdev-go/go-text: version bump to 0.3.0 (diff)
downloadgentoo-0a04bb4a4ba5f2a56361f4fb40fcbf70e531feb6.tar.gz
gentoo-0a04bb4a4ba5f2a56361f4fb40fcbf70e531feb6.tar.bz2
gentoo-0a04bb4a4ba5f2a56361f4fb40fcbf70e531feb6.zip
dev-go/go-sys: version bump to 0_pre20180816
Package-Manager: Portage-2.3.47, Repoman-2.3.10
Diffstat (limited to 'dev-go/go-sys/go-sys-0_pre20180816.ebuild')
-rw-r--r--dev-go/go-sys/go-sys-0_pre20180816.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-go/go-sys/go-sys-0_pre20180816.ebuild b/dev-go/go-sys/go-sys-0_pre20180816.ebuild
new file mode 100644
index 000000000000..e42e90c0451b
--- /dev/null
+++ b/dev-go/go-sys/go-sys-0_pre20180816.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN=golang.org/x/sys/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ EGIT_COMMIT="1c9583448a9c3aa0f9a6a5241bf73c0bd8aafded"
+ SRC_URI="https://github.com/golang/sys/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go packages for low-level interaction with the operating system"
+HOMEPAGE="https://godoc.org/golang.org/x/sys"
+LICENSE="BSD"
+SLOT="0/${PVR}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ GOPATH="${S}" \
+ go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
+}
+
+src_test() {
+ GOPATH="${S}" \
+ go test -v -work -x "${EGO_PN}" || die
+}
+
+src_install() {
+ golang_install_pkgs
+}