summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-08-24 17:43:23 -0500
committerWilliam Hubbs <williamh@gentoo.org>2015-08-24 18:01:28 -0500
commitc146fff2423906d61cfc34d41b6c60866b3ded3e (patch)
tree03fb1d3b5ca5916b4a87493875969978d03e530f /dev-go/sanitized-anchor-name/sanitized-anchor-name-9999.ebuild
parentprofiles: stable mask the qt5 USE flag again on amd64 and hppa (diff)
downloadgentoo-c146fff2423906d61cfc34d41b6c60866b3ded3e.tar.gz
gentoo-c146fff2423906d61cfc34d41b6c60866b3ded3e.tar.bz2
gentoo-c146fff2423906d61cfc34d41b6c60866b3ded3e.zip
dev-go/sanitized-anchor-name: new package
This is a library which provides sanitized anchor names. It is a third party library used by the blackfriday markdown processor.
Diffstat (limited to 'dev-go/sanitized-anchor-name/sanitized-anchor-name-9999.ebuild')
-rw-r--r--dev-go/sanitized-anchor-name/sanitized-anchor-name-9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-go/sanitized-anchor-name/sanitized-anchor-name-9999.ebuild b/dev-go/sanitized-anchor-name/sanitized-anchor-name-9999.ebuild
new file mode 100644
index 000000000000..3eec0dc4c15a
--- /dev/null
+++ b/dev-go/sanitized-anchor-name/sanitized-anchor-name-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+EGO_PN=github.com/shurcooL/sanitized_anchor_name
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="244f5ac"
+ SRC_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="A Go function to provide sanitized anchor names"
+HOMEPAGE="https://github.com/shurcooL/sanitized_anchor_name"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND=""
+RDEPEND=""