summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-go/sarama
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-go/sarama')
-rw-r--r--dev-go/sarama/Manifest1
-rw-r--r--dev-go/sarama/metadata.xml10
-rw-r--r--dev-go/sarama/sarama-1.4.3.ebuild68
-rw-r--r--dev-go/sarama/sarama-9999.ebuild39
4 files changed, 118 insertions, 0 deletions
diff --git a/dev-go/sarama/Manifest b/dev-go/sarama/Manifest
new file mode 100644
index 000000000000..5f140414597a
--- /dev/null
+++ b/dev-go/sarama/Manifest
@@ -0,0 +1 @@
+DIST sarama-1.4.3.tar.gz 86096 SHA256 2e9ad67fd128b139e4a55532f07dff21d9705884ac6063b6f494a3b6db728688 SHA512 6117d08b1f7dc7feebacee60a3672d24ec909417a40dd686fdba9740304522c74d59f866ab37a90fdbd137bb491175d2cdf2694129f2da5d8c10dff97efb062b WHIRLPOOL a829d60790820d90179e9b30dcff1e4eaab5caecdaba072945a7223a8a2697ebb40abd4a7179fff50cd1598ac6b85adeb74c7d9c2464ead9acc906913b24d0c9
diff --git a/dev-go/sarama/metadata.xml b/dev-go/sarama/metadata.xml
new file mode 100644
index 000000000000..061f4c09127e
--- /dev/null
+++ b/dev-go/sarama/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Shopify/sarama</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-go/sarama/sarama-1.4.3.ebuild b/dev-go/sarama/sarama-1.4.3.ebuild
new file mode 100644
index 000000000000..3b5a71914bf6
--- /dev/null
+++ b/dev-go/sarama/sarama-1.4.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_SRC=github.com/Shopify/${PN}
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+inherit golang-build
+
+DESCRIPTION="Sarama is a Go library for Apache Kafka"
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="test"
+DEPEND="dev-go/go-eapache-queue
+ dev-go/go-resiliency
+ dev-go/go-snappy
+ test? ( dev-go/go-spew )"
+RDEPEND=""
+
+if [[ ${PV} != *9999* ]]; then
+src_unpack() {
+ local f
+
+ for f in ${A}
+ do
+ case "${f}" in
+ *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
+ local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
+
+ debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
+
+ # XXX: check whether the directory structure inside is
+ # fine? i.e. if the tarball has actually a parent dir.
+ mkdir -p "${destdir}" || die
+ tar -C "${destdir}" -x --strip-components 1 \
+ -f "${DISTDIR}/${f}" || die
+ ;;
+ *)
+ debug-print "${FUNCNAME}: falling back to unpack for ${f}"
+
+ # fall back to the default method
+ unpack "${f}"
+ ;;
+ esac
+ done
+}
+fi
+
+src_prepare() {
+ # avoid toxiproxy dependency
+ rm src/${EGO_SRC}/functional*_test.go || die
+}
+
+src_install() {
+ rm -rf src/${EGO_SRC}/.git* || die
+ golang-build_src_install
+ rm bin/http_server || die
+ dobin bin/*
+}
diff --git a/dev-go/sarama/sarama-9999.ebuild b/dev-go/sarama/sarama-9999.ebuild
new file mode 100644
index 000000000000..c4c8ebff92bc
--- /dev/null
+++ b/dev-go/sarama/sarama-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_SRC=github.com/Shopify/${PN}
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Sarama is a Go library for Apache Kafka"
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="MIT"
+SLOT="0/${PV}"
+IUSE="test"
+DEPEND="dev-go/go-eapache-queue
+ dev-go/go-resiliency
+ dev-go/go-snappy
+ test? ( dev-go/go-spew )"
+RDEPEND=""
+
+src_prepare() {
+ # avoid toxiproxy dependency
+ rm src/${EGO_SRC}/functional*_test.go || die
+}
+
+src_install() {
+ golang-build_src_install
+ rm bin/http_server || die
+ dobin bin/*
+}