summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-02-20 14:38:32 -0800
committerZac Medico <zmedico@gentoo.org>2016-02-20 14:39:12 -0800
commit128145b9bedd7140cb7d195457f3e55b9657ff4b (patch)
tree86697bcb8459b400ff4238465aead84d8c83e96f /dev-go
parentdev-vcs/gitolite-gentoo: bump. (diff)
downloadgentoo-128145b9bedd7140cb7d195457f3e55b9657ff4b.tar.gz
gentoo-128145b9bedd7140cb7d195457f3e55b9657ff4b.tar.bz2
gentoo-128145b9bedd7140cb7d195457f3e55b9657ff4b.zip
dev-go/go-protobuf: version bump to 0_pre20160216
Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-protobuf/Manifest1
-rw-r--r--dev-go/go-protobuf/go-protobuf-0_pre20160216.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-go/go-protobuf/Manifest b/dev-go/go-protobuf/Manifest
index fe2000ee0b00..c6d537fdb2ce 100644
--- a/dev-go/go-protobuf/Manifest
+++ b/dev-go/go-protobuf/Manifest
@@ -1 +1,2 @@
DIST go-protobuf-0_pre20150809.tar.gz 151982 SHA256 160ad98eb1477492476ba566d218262fe6d326410d5a030c6a00433eaf7f9006 SHA512 04802b8d74ccaa17f9fc030badd0e74b6e47233ca5f1faab7c49f25bef2f06efd97aa4bf3f4783a7815958354744ddb9fee96d183aebbb03864069b0cc569564 WHIRLPOOL f49157a4a1a48c67b72ed38121ba28aec3f9b3405a3388097caba36643715c14b6915f9bcbd04f974fa98e9f2c4c4a4e313480ef307701c0ace734e9c214c010
+DIST go-protobuf-0_pre20160216.tar.gz 198638 SHA256 c6435eb03e34de0c35577e68fac76ce942785551ac4d3c0f7a7b0fdb8e9285f5 SHA512 d7f446ce7b3f78d646abccdbcb92c423fcca99a51275b55f2a357b5e44c2a6b6d7ea59a39b654daa36e59aa39d3b094ed3fb3d6f53c789a4396fceaecbd5ace5 WHIRLPOOL 900d1aef9a9ef3960732d2ca5b16e4e524964355a91bd283ccb2550c3e84da58b03da6bf2f45ff1e00efddc5d2add71d76829502cdaf4c807f63166f731151f2
diff --git a/dev-go/go-protobuf/go-protobuf-0_pre20160216.ebuild b/dev-go/go-protobuf/go-protobuf-0_pre20160216.ebuild
new file mode 100644
index 000000000000..12a260858c9a
--- /dev/null
+++ b/dev-go/go-protobuf/go-protobuf-0_pre20160216.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EGO_SRC=github.com/golang/protobuf
+EGO_PN=${EGO_SRC}/...
+
+if [[ ${PV} = *9999* ]]; then
+ inherit golang-vcs
+else
+ KEYWORDS="~amd64"
+ EGIT_COMMIT="127091107ff5f822298f1faa7487ffcf578adcf6"
+ SRC_URI="https://${EGO_SRC}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
+fi
+inherit golang-build
+
+DESCRIPTION="Go support for Google's protocol buffers"
+HOMEPAGE="https://${EGO_SRC}"
+LICENSE="BSD"
+SLOT="0/${PVR}"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_install() {
+ rm -rf src/${EGO_SRC}/.git* || die
+ golang-build_src_install
+ dobin bin/*
+}