summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-07-25 05:37:52 +1000
committerSam James <sam@gentoo.org>2022-07-24 23:05:16 +0100
commitda4a1599d1cb86032773e6bcd42e547b8dd4ff87 (patch)
tree21b41f6ec1783ea2354660792e6817a4828bbfe9 /dev-haskell/aeson-diff
parentsys-kernel/git-sources: add 5.19_rc8 (diff)
downloadgentoo-da4a1599d1cb86032773e6bcd42e547b8dd4ff87.tar.gz
gentoo-da4a1599d1cb86032773e6bcd42e547b8dd4ff87.tar.bz2
gentoo-da4a1599d1cb86032773e6bcd42e547b8dd4ff87.zip
dev-haskell/aeson-diff: add 1.1.0.9
Closes: https://bugs.gentoo.org/860741 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/aeson-diff')
-rw-r--r--dev-haskell/aeson-diff/Manifest1
-rw-r--r--dev-haskell/aeson-diff/aeson-diff-1.1.0.9.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-haskell/aeson-diff/Manifest b/dev-haskell/aeson-diff/Manifest
index 54c6ad89ebfc..b04a1ee1a49c 100644
--- a/dev-haskell/aeson-diff/Manifest
+++ b/dev-haskell/aeson-diff/Manifest
@@ -1 +1,2 @@
DIST aeson-diff-1.1.0.8.tar.gz 16521 BLAKE2B fb72ea03dc4b35791f151f22c4fab3f9cafecd604c520137c79af5e4c71772399516d0120bd01e2335fbf7747525babedf5603e5e8d3ba244a9907c81c9f1ea8 SHA512 5a5f703dec592c0cfd825eb1899006350649c52bf810ff1aaaf4134ebfbc11f5fbe9e7f158a8c3a21dbef4902b1f9e94148bc116e27418b2b786f6d31c7561fb
+DIST aeson-diff-1.1.0.9.tar.gz 16227 BLAKE2B 8bde3a62353e2ae5d6c5ceb2862da5537908bf3231d590c20dea24e820928b526ee84b463aef28e448f28a399f9a64dd8dcb6058f75999a9636866a59dd913c4 SHA512 2778eabe53ac0520028c9eccae7f52dcdeb2eccb4df4ff6a84e4625afc5d46533ebf61b6b99c16eb5ffe9792e781b0f9a8e1e43c2b69b751d1dbc5dd627635d9
diff --git a/dev-haskell/aeson-diff/aeson-diff-1.1.0.9.ebuild b/dev-haskell/aeson-diff/aeson-diff-1.1.0.9.ebuild
new file mode 100644
index 000000000000..1d4b1fc48bed
--- /dev/null
+++ b/dev-haskell/aeson-diff/aeson-diff-1.1.0.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Extract and apply patches to JSON documents"
+HOMEPAGE="https://github.com/thsutton/aeson-diff"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Ambiguous module name ‘Data.Vector’: found in multiple packages: AC-Vector-Fancy-2.4.0 vector-0.12.0.2
+RESTRICT=test
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/edit-distance-vector:=[profile?]
+ dev-haskell/hashable:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/optparse-applicative:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+ test? ( >=dev-haskell/doctest-0.9
+ dev-haskell/glob
+ dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances )
+"
+
+src_prepare() {
+ default
+ cabal_chdeps \
+ 'base >=4.9 && <4.15' 'base >=4.9'
+}