summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-29 12:47:58 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:00:55 +0100
commite575257ce2017bc20891ec3f67168f5fdd7e6fd9 (patch)
tree4399ca55dd65dbe86556b6d9efce98cf8d0b534f /dev-haskell/aeson-diff
parentdev-haskell/edit-distance-vector: add package (diff)
downloadgentoo-e575257ce2017bc20891ec3f67168f5fdd7e6fd9.tar.gz
gentoo-e575257ce2017bc20891ec3f67168f5fdd7e6fd9.tar.bz2
gentoo-e575257ce2017bc20891ec3f67168f5fdd7e6fd9.zip
dev-haskell/aeson-diff: add package
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/aeson-diff')
-rw-r--r--dev-haskell/aeson-diff/Manifest1
-rw-r--r--dev-haskell/aeson-diff/aeson-diff-1.1.0.8.ebuild48
-rw-r--r--dev-haskell/aeson-diff/metadata.xml15
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-haskell/aeson-diff/Manifest b/dev-haskell/aeson-diff/Manifest
new file mode 100644
index 000000000000..54c6ad89ebfc
--- /dev/null
+++ b/dev-haskell/aeson-diff/Manifest
@@ -0,0 +1 @@
+DIST aeson-diff-1.1.0.8.tar.gz 16521 BLAKE2B fb72ea03dc4b35791f151f22c4fab3f9cafecd604c520137c79af5e4c71772399516d0120bd01e2335fbf7747525babedf5603e5e8d3ba244a9907c81c9f1ea8 SHA512 5a5f703dec592c0cfd825eb1899006350649c52bf810ff1aaaf4134ebfbc11f5fbe9e7f158a8c3a21dbef4902b1f9e94148bc116e27418b2b786f6d31c7561fb
diff --git a/dev-haskell/aeson-diff/aeson-diff-1.1.0.8.ebuild b/dev-haskell/aeson-diff/aeson-diff-1.1.0.8.ebuild
new file mode 100644
index 000000000000..d44881aa49be
--- /dev/null
+++ b/dev-haskell/aeson-diff/aeson-diff-1.1.0.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Extract and apply patches to JSON documents"
+HOMEPAGE="https://github.com/thsutton/aeson-diff"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Ambiguous module name ‘Data.Vector’: found in multiple packages: AC-Vector-Fancy-2.4.0 vector-0.12.0.2
+RESTRICT=test
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/edit-distance-vector:=[profile?]
+ dev-haskell/hashable:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/optparse-applicative:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+ test? ( >=dev-haskell/doctest-0.9
+ dev-haskell/glob
+ dev-haskell/hlint
+ dev-haskell/quickcheck
+ dev-haskell/quickcheck-instances )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >=4.9 && <4.14' 'base >=4.9'
+}
diff --git a/dev-haskell/aeson-diff/metadata.xml b/dev-haskell/aeson-diff/metadata.xml
new file mode 100644
index 000000000000..e984d020b504
--- /dev/null
+++ b/dev-haskell/aeson-diff/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <longdescription>
+
+ This is a small library for working with changes to JSON documents. It
+ includes a library and two command-line executables in the style of the
+ diff(1) and patch(1) commands available on many systems.
+
+ </longdescription>
+</pkgmetadata>