summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-12-27 23:19:43 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-12-27 23:19:59 +0000
commit72c564afc88556732b09e4b4b2cbf0f1b191900b (patch)
treee01bcd79140e327d1434393191efec2a1d6c26bd /dev-haskell/alex
parentnet-news/newsboat: drop 2.17.1-r1 (diff)
downloadgentoo-72c564afc88556732b09e4b4b2cbf0f1b191900b.tar.gz
gentoo-72c564afc88556732b09e4b4b2cbf0f1b191900b.tar.bz2
gentoo-72c564afc88556732b09e4b4b2cbf0f1b191900b.zip
dev-haskell/alex: use inplace alex for tests, bug #703920
Reported-by: Toralf Förster Closes: https://bugs.gentoo.org/703920 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/alex')
-rw-r--r--dev-haskell/alex/alex-3.2.4.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-haskell/alex/alex-3.2.4.ebuild b/dev-haskell/alex/alex-3.2.4.ebuild
index 0adfe9957174..d25604349f3f 100644
--- a/dev-haskell/alex/alex-3.2.4.ebuild
+++ b/dev-haskell/alex/alex-3.2.4.ebuild
@@ -57,8 +57,10 @@ src_compile() {
}
src_test() {
- # workaround https://github.com/haskell/cabal/issues/2398
- emake -k -C tests all
+ # 1. workaround Setup.hs deadlock: https://github.com/haskell/cabal/issues/2398
+ # 2. use freshly built ALEX= binary and datadir path
+ alex_datadir="${S}"/data \
+ emake -k -C tests all ALEX="${S}"/dist/build/alex/alex
}
src_install() {