summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/arrows
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/arrows')
-rw-r--r--dev-haskell/arrows/Manifest2
-rw-r--r--dev-haskell/arrows/arrows-0.4.4.0.ebuild22
-rw-r--r--dev-haskell/arrows/arrows-0.4.4.1-r1.ebuild22
-rw-r--r--dev-haskell/arrows/arrows-0.4.4.1.ebuild22
-rw-r--r--dev-haskell/arrows/metadata.xml8
5 files changed, 76 insertions, 0 deletions
diff --git a/dev-haskell/arrows/Manifest b/dev-haskell/arrows/Manifest
new file mode 100644
index 000000000000..7bf3c2fd2d8c
--- /dev/null
+++ b/dev-haskell/arrows/Manifest
@@ -0,0 +1,2 @@
+DIST arrows-0.4.4.0.tar.gz 12393 SHA256 4999ba909061f5bede09e6116e2cac1cf89f04d3429a4a2be6ef79a677d89bb5 SHA512 5042ef79e9ee03d4a6f303b0d943f5f8f2733b084a00257e4c93b7792b365115322b118f6620093b2a55b6804b1c3e5ddb9118bd356f46a6621243d21970d557 WHIRLPOOL ecb9ce9df89df4f9c226e0165a434a594aa8797e1f1ac701854128a58f615d972a749175fca9dc810b445f665c882fdac838d136f1582df874c26ea2a2b7628b
+DIST arrows-0.4.4.1.tar.gz 12261 SHA256 5b104bd8f8fac5ad0fd194088819423302e52c2a796cc99f6d32bbc134bfebe2 SHA512 642bc893ba5a01d139498fdd8d97531daf76c583eee3317ee7b0cb15bdd5304022a0c7d9280d1eef58bba40de9782cea01325c8fed45232c15261c49b060d352 WHIRLPOOL 69b8caad113fb2e14236fa66e99dee8a2d9e11a2b19e8f875fd9d776a4894d4a6dcccefe1de928c4ceae302021b61d1d01fa785498000720451d606b30ce0b37
diff --git a/dev-haskell/arrows/arrows-0.4.4.0.ebuild b/dev-haskell/arrows/arrows-0.4.4.0.ebuild
new file mode 100644
index 000000000000..4c93d91fa638
--- /dev/null
+++ b/dev-haskell/arrows/arrows-0.4.4.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Arrow classes and transformers"
+HOMEPAGE="http://www.haskell.org/arrows/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ~ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="dev-haskell/stream[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ dev-haskell/cabal"
diff --git a/dev-haskell/arrows/arrows-0.4.4.1-r1.ebuild b/dev-haskell/arrows/arrows-0.4.4.1-r1.ebuild
new file mode 100644
index 000000000000..6e0c0945402b
--- /dev/null
+++ b/dev-haskell/arrows/arrows-0.4.4.1-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Arrow classes and transformers"
+HOMEPAGE="http://www.haskell.org/arrows/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ~ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="dev-haskell/stream:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-0"
diff --git a/dev-haskell/arrows/arrows-0.4.4.1.ebuild b/dev-haskell/arrows/arrows-0.4.4.1.ebuild
new file mode 100644
index 000000000000..2cd80cf04fcc
--- /dev/null
+++ b/dev-haskell/arrows/arrows-0.4.4.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Arrow classes and transformers"
+HOMEPAGE="http://www.haskell.org/arrows/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc ~ppc64 sparc x86"
+IUSE=""
+
+RDEPEND="dev-haskell/stream[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ dev-haskell/cabal"
diff --git a/dev-haskell/arrows/metadata.xml b/dev-haskell/arrows/metadata.xml
new file mode 100644
index 000000000000..8c66906af531
--- /dev/null
+++ b/dev-haskell/arrows/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>haskell</herd>
+<maintainer>
+ <email>haskell@gentoo.org</email>
+</maintainer>
+</pkgmetadata>