summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-16 17:25:41 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:42:39 +0000
commit1c4f3e10fc4560e233ef39bd508065dad07dcace (patch)
tree1a35ac0b02c6047f25e2495298af35a613ca0500 /dev-haskell/asn1-data/asn1-data-0.7.2.ebuild
parentdev-haskell/ansi-wl-pprint: bump up to 0.6.7.3 (diff)
downloadgentoo-1c4f3e10fc4560e233ef39bd508065dad07dcace.tar.gz
gentoo-1c4f3e10fc4560e233ef39bd508065dad07dcace.tar.bz2
gentoo-1c4f3e10fc4560e233ef39bd508065dad07dcace.zip
dev-haskell/asn1-data: bump up to 0.7.2
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-haskell/asn1-data/asn1-data-0.7.2.ebuild')
-rw-r--r--dev-haskell/asn1-data/asn1-data-0.7.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-haskell/asn1-data/asn1-data-0.7.2.ebuild b/dev-haskell/asn1-data/asn1-data-0.7.2.ebuild
new file mode 100644
index 000000000000..afb3e2f209de
--- /dev/null
+++ b/dev-haskell/asn1-data/asn1-data-0.7.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+#hackport: flags: -test
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="ASN1 data reader and writer in RAW, BER and DER forms"
+HOMEPAGE="https://github.com/vincenthz/hs-asn1/tree/master/data"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/cereal:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-test
+}