summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-15 23:20:28 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 10:21:52 +0000
commit65087929ac61d5b4f4e889a944fd530d93654ee3 (patch)
tree18f4e430b56a39e247316252ff3d165b5fe4457a /dev-haskell/aws
parentdev-haskell/errors: bump up to 2.1.3 (diff)
downloadgentoo-65087929ac61d5b4f4e889a944fd530d93654ee3.tar.gz
gentoo-65087929ac61d5b4f4e889a944fd530d93654ee3.tar.bz2
gentoo-65087929ac61d5b4f4e889a944fd530d93654ee3.zip
dev-haskell/aws: bump up to 0.14.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell/aws')
-rw-r--r--dev-haskell/aws/Manifest1
-rw-r--r--dev-haskell/aws/aws-0.14.1.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-haskell/aws/Manifest b/dev-haskell/aws/Manifest
index f0b44859e48e..2f356b5296bb 100644
--- a/dev-haskell/aws/Manifest
+++ b/dev-haskell/aws/Manifest
@@ -1,2 +1,3 @@
DIST aws-0.11.3.tar.gz 90102 SHA256 14a9a9f4435f92b9a0364de66469e293f3ad09c7fe54aacce3486280866de30a SHA512 0343d8ef17ad06525c7c131eb97408d3298c46f4dd472604bd4b3a20c2bb1e880e12f9a0e345ee2fe9bfe56b684fd653e9a99b7919e8d97fce4ca0cdd720afb5 WHIRLPOOL 49e49b802c0c996d3b94d68dafcc3eed82f0b104f1a339e1ff3f9c8e12638543021394c79d24bbba3cf51c3f2a6c8638f71b8be8f8ca7e7c656924c52700ebc3
DIST aws-0.12.1.tar.gz 90763 SHA256 6c85bac359ea94d78f287b45c6e7e981dc260a1c029a7888ed752a1c0e64d32b SHA512 8c89a982196b654ad4f001d30cb415a9272aacb582c8879173babc4183ca4eb21c025399f1bb5e2624a77a1c38da9b4637bf1dfa0a5bbccb888808a5e654bbf9 WHIRLPOOL 2a82e24cac4011b02408e76122fbbb3d7b871c907503da8a167b5d81752b4c4ecc766fd6095345694f1283ff28c4766f1c8c7254d3ff8e37a2dd1d6268d2731f
+DIST aws-0.14.1.tar.gz 95017 SHA256 6a2079853ddc781b46fe3ddce31e88c0b6b2441f458141bca3cd1c7216cbe579 SHA512 0616d085291748d3ec1ef24d7914562f85fde0577f8100b0dd7f8bc2c817fffb4945372fb80aad98dce652fbf1f063a55afe3ba7aff89ddd5bcd2ba43047ad8c WHIRLPOOL 30240cd081f1c06aca1255e3f41c60a04f543b053c54f436988c7ce829cbc3549a871411f02073b3b078428a28621c5d2b495635a5b3cb4dd56f18a386e139ea
diff --git a/dev-haskell/aws/aws-0.14.1.ebuild b/dev-haskell/aws/aws-0.14.1.ebuild
new file mode 100644
index 000000000000..7033bbc981da
--- /dev/null
+++ b/dev-haskell/aws/aws-0.14.1.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Amazon Web Services (AWS) for Haskell"
+HOMEPAGE="https://github.com/aristidb/aws"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RESTRICT=test # needs aws accound
+
+RDEPEND=">=dev-haskell/aeson-0.6:=[profile?]
+ >=dev-haskell/attoparsec-0.11:=[profile?] <dev-haskell/attoparsec-0.14:=[profile?]
+ >=dev-haskell/base16-bytestring-0.1:=[profile?] <dev-haskell/base16-bytestring-0.2:=[profile?]
+ >=dev-haskell/base64-bytestring-1.0:=[profile?] <dev-haskell/base64-bytestring-1.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.5:=[profile?]
+ >=dev-haskell/byteable-0.1:=[profile?] <dev-haskell/byteable-0.2:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/cereal-0.3:=[profile?] <dev-haskell/cereal-0.6:=[profile?]
+ >=dev-haskell/conduit-1.1:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ >=dev-haskell/conduit-extra-1.1:=[profile?] <dev-haskell/conduit-extra-1.2:=[profile?]
+ >=dev-haskell/cryptohash-0.11:=[profile?] <dev-haskell/cryptohash-0.12:=[profile?]
+ >=dev-haskell/data-default-0.5.3:=[profile?] <dev-haskell/data-default-0.8:=[profile?]
+ >=dev-haskell/http-conduit-2.1:=[profile?] <dev-haskell/http-conduit-2.2:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?] <dev-haskell/http-types-0.10:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?] <dev-haskell/lifted-base-0.3:=[profile?]
+ >=dev-haskell/monad-control-0.3:=[profile?]
+ >=dev-haskell/mtl-2:=[profile?] <dev-haskell/mtl-3:=[profile?]
+ >=dev-haskell/network-2:=[profile?] <dev-haskell/network-3:=[profile?]
+ >=dev-haskell/old-locale-1:=[profile?] <dev-haskell/old-locale-2:=[profile?]
+ >=dev-haskell/resourcet-1.1:=[profile?] <dev-haskell/resourcet-1.2:=[profile?]
+ >=dev-haskell/safe-0.3:=[profile?] <dev-haskell/safe-0.4:=[profile?]
+ >=dev-haskell/scientific-0.3:=[profile?]
+ >=dev-haskell/tagged-0.7:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/vector-0.10:=[profile?]
+ >=dev-haskell/xml-conduit-1.2:=[profile?] <dev-haskell/xml-conduit-1.4:=[profile?]
+ >=dev-lang/ghc-7.8.2:=
+ examples? ( >=dev-haskell/errors-2.0:=[profile?]
+ dev-haskell/exceptions:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.18.1.3
+ test? ( >=dev-haskell/aeson-0.7
+ >=dev-haskell/http-client-0.3 <dev-haskell/http-client-0.5
+ <dev-haskell/http-client-tls-0.5
+ >=dev-haskell/lifted-base-0.2
+ >=dev-haskell/mtl-2.1
+ >=dev-haskell/quickcheck-2.7
+ >=dev-haskell/quickcheck-instances-0.3
+ >=dev-haskell/tasty-0.8
+ >=dev-haskell/tasty-hunit-0.8
+ >=dev-haskell/tasty-quickcheck-0.8
+ >=dev-haskell/text-1.1
+ >=dev-haskell/transformers-base-0.4
+ !examples? ( >=dev-haskell/errors-2.0 ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples examples)
+}