summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-11 19:15:05 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:14:53 +0000
commitca02511011995263336aa4829efb35f1944cc4a8 (patch)
treeacab1e0706f7ef47777585fd069f337537fa88a5 /dev-haskell/bifunctors
parentdev-haskell/base-orphans: keyword 0.8.4 for ~ppc64 (diff)
downloadgentoo-ca02511011995263336aa4829efb35f1944cc4a8.tar.gz
gentoo-ca02511011995263336aa4829efb35f1944cc4a8.tar.bz2
gentoo-ca02511011995263336aa4829efb35f1944cc4a8.zip
dev-haskell/bifunctors: add 5.5.11
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/bifunctors')
-rw-r--r--dev-haskell/bifunctors/Manifest1
-rw-r--r--dev-haskell/bifunctors/bifunctors-5.5.11.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-haskell/bifunctors/Manifest b/dev-haskell/bifunctors/Manifest
index aa1e6df93082..3a1f7ac650eb 100644
--- a/dev-haskell/bifunctors/Manifest
+++ b/dev-haskell/bifunctors/Manifest
@@ -1 +1,2 @@
+DIST bifunctors-5.5.11.tar.gz 46003 BLAKE2B 82572e6c162ab105fdce6c3cd7e44da16db232c2233e4d2e3551001a20a2bff0bb4e41fabebc974290749275621a9b0abe3925156090cb960b95e8cbcf43150d SHA512 09f66d1a086a72a822e804521c2258acb16fd5a4a29c3758b97987f27a271f58e3dd4103518b31b3bdf44465c87fe5573a0bba168ba109287ca3370b8ab491a1
DIST bifunctors-5.5.6.tar.gz 44721 BLAKE2B 9f0d588ad514b60ac6ac5fc1f5e1c265b111330e008d57340baee4011e6aadbdaa9a7d24b480cd7d568f57e61214821129ce8785a5731763a08306a2c8151b5a SHA512 d78471bdf9c83c77d49825321984964e165c77ee4f02f8c4232ce272246057b0064b68553f8d70a11a930fc771dc55a2991ff63d6d7af89bb749f23737ba6a5b
diff --git a/dev-haskell/bifunctors/bifunctors-5.5.11.ebuild b/dev-haskell/bifunctors/bifunctors-5.5.11.ebuild
new file mode 100644
index 000000000000..8f266bcb81f0
--- /dev/null
+++ b/dev-haskell/bifunctors/bifunctors-5.5.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.7.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="The Bifunctors package authored by Edward Kmett"
+HOMEPAGE="https://github.com/ekmett/bifunctors/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="+semigroups +tagged"
+
+RDEPEND=">=dev-haskell/base-orphans-0.8.4:=[profile?] <dev-haskell/base-orphans-1:=[profile?]
+ >=dev-haskell/comonad-5.0.7:=[profile?] <dev-haskell/comonad-6:=[profile?]
+ >=dev-haskell/th-abstraction-0.4.2.0:=[profile?] <dev-haskell/th-abstraction-0.5:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ tagged? ( >=dev-haskell/tagged-0.8.6:=[profile?] <dev-haskell/tagged-1:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/hspec-1.8
+ >=dev-haskell/quickcheck-2 <dev-haskell/quickcheck-3
+ dev-haskell/transformers-compat )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag semigroups semigroups) \
+ $(cabal_flag tagged tagged)
+}