summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-12-03 18:57:20 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-12-03 18:57:20 +0000
commitd3f5009d3907e25e9db8153bca67e105f2ab6345 (patch)
treee3cdab068382d3bd08048d23ebfd6d13541db234 /dev-haskell/cabal/cabal-2.0.0.2.ebuild
parentmedia-gfx/sam2p: stable 0.49.3 for hppa, bug #617014 (diff)
downloadgentoo-d3f5009d3907e25e9db8153bca67e105f2ab6345.tar.gz
gentoo-d3f5009d3907e25e9db8153bca67e105f2ab6345.tar.bz2
gentoo-d3f5009d3907e25e9db8153bca67e105f2ab6345.zip
dev-haskell/cabal: bump up to 2.0.0.2, bug #635268
ghc-8.2 branch needs at least Cabal-2. Closes: https://bugs.gentoo.org/635268 Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'dev-haskell/cabal/cabal-2.0.0.2.ebuild')
-rw-r--r--dev-haskell/cabal/cabal-2.0.0.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/cabal/cabal-2.0.0.2.ebuild b/dev-haskell/cabal/cabal-2.0.0.2.ebuild
new file mode 100644
index 000000000000..6940bc3c4e4d
--- /dev/null
+++ b/dev-haskell/cabal/cabal-2.0.0.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.3.9999
+#hackport: flags: -parsec-struct-diff
+
+CABAL_FEATURES="lib profile test-suite"
+CABAL_FEATURES+=" nocabaldep" # in case installed Cabal is broken
+inherit haskell-cabal
+
+MY_PN="Cabal"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A framework for packaging Haskell software"
+HOMEPAGE="http://www.haskell.org/cabal/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+#not keyworded yet: many packages are broken
+#KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RESTRICT=test # circular dependencies
+
+RDEPEND=">=dev-lang/ghc-7.8.1:="
+DEPEND="${RDEPEND}"
+
+CABAL_CORE_LIB_GHC_PV="PM:8.2.1"
+
+PATCHES=("${FILESDIR}"/${P}-no-bootstrap.patch)
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-parsec-struct-diff
+}