summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/cipher-camellia
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/cipher-camellia')
-rw-r--r--dev-haskell/cipher-camellia/Manifest2
-rw-r--r--dev-haskell/cipher-camellia/cipher-camellia-0.0.1.ebuild33
-rw-r--r--dev-haskell/cipher-camellia/cipher-camellia-0.0.2.ebuild33
-rw-r--r--dev-haskell/cipher-camellia/metadata.xml11
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-haskell/cipher-camellia/Manifest b/dev-haskell/cipher-camellia/Manifest
new file mode 100644
index 000000000000..3ebdd27c0907
--- /dev/null
+++ b/dev-haskell/cipher-camellia/Manifest
@@ -0,0 +1,2 @@
+DIST cipher-camellia-0.0.1.tar.gz 6232 SHA256 03e2385bf161a2bc01e4ce9fc46bee678eea61ffc8e3064f18679f0309cdca86 SHA512 bfa94a82c908b59e998cedf816bd7d8739e55308627c4395e0e19f782f186a4bfd406ed21796e3a9480b89ddffae42242b124968e5d752cdc79c8044d33d7638 WHIRLPOOL 6dab50ad6a6a2dafc4eb6c2dfe5942e9e20bf44ebb3ec1007b7624eb3dbcfd980f5c0824f2a90c83aaa4e773eac8ad24b14483bdff12fd30d71ca1e12c849abb
+DIST cipher-camellia-0.0.2.tar.gz 6230 SHA256 8d0cd137cdb890646bb5d3bb52b20fa6d74e1b0c35d7d524d60edd9d43ace2a7 SHA512 d3094d2b190023b6afbab20f7d1c01826f56b7c99ea0c9613fcb14c8d3f3f3c3e16b57c2643a9df2bcf12cc97596cd32dd717fedf81fd84a9cdb9f46f308e130 WHIRLPOOL 57840e4d295917287697ade7507d5f4c38846536b48a431c917318af91ef030c254e78dc7b5d04efc33ebf10c426e88914ce65902b688da07fcf5acbec016c87
diff --git a/dev-haskell/cipher-camellia/cipher-camellia-0.0.1.ebuild b/dev-haskell/cipher-camellia/cipher-camellia-0.0.1.ebuild
new file mode 100644
index 000000000000..f6b1ea1ad1af
--- /dev/null
+++ b/dev-haskell/cipher-camellia/cipher-camellia-0.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Camellia block cipher primitives"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.3:=[profile?]
+ >=dev-haskell/securemem-0.1.2:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/crypto-cipher-tests
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
diff --git a/dev-haskell/cipher-camellia/cipher-camellia-0.0.2.ebuild b/dev-haskell/cipher-camellia/cipher-camellia-0.0.2.ebuild
new file mode 100644
index 000000000000..7e4018f85bb7
--- /dev/null
+++ b/dev-haskell/cipher-camellia/cipher-camellia-0.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Camellia block cipher primitives"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-cipher"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/crypto-cipher-types-0.0.3:=[profile?] <dev-haskell/crypto-cipher-types-0.1:=[profile?]
+ >=dev-haskell/securemem-0.1.2:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/crypto-cipher-tests
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
diff --git a/dev-haskell/cipher-camellia/metadata.xml b/dev-haskell/cipher-camellia/metadata.xml
new file mode 100644
index 000000000000..480d4f03c9cb
--- /dev/null
+++ b/dev-haskell/cipher-camellia/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Camellia block cipher primitives
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-crypto-cipher</remote-id>
+ </upstream>
+</pkgmetadata>