summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-07-12 00:31:42 -0400
committerSam James <sam@gentoo.org>2022-07-22 22:14:56 +0000
commit5825792c2380157f5f7b6b0c738379e46b4b7471 (patch)
tree247b6a7644975266dd7de1cdb8381ff3e1aca3da /dev-haskell/citeproc
parentdev-haskell/charset: keyword 0.3.7.1-r1 for ~ppc64 (diff)
downloadgentoo-5825792c2380157f5f7b6b0c738379e46b4b7471.tar.gz
gentoo-5825792c2380157f5f7b6b0c738379e46b4b7471.tar.bz2
gentoo-5825792c2380157f5f7b6b0c738379e46b4b7471.zip
dev-haskell/citeproc: add 0.7
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/citeproc')
-rw-r--r--dev-haskell/citeproc/Manifest1
-rw-r--r--dev-haskell/citeproc/citeproc-0.7.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-haskell/citeproc/Manifest b/dev-haskell/citeproc/Manifest
index f8f5b0bf5577..53eddb7f51ae 100644
--- a/dev-haskell/citeproc/Manifest
+++ b/dev-haskell/citeproc/Manifest
@@ -1 +1,2 @@
DIST citeproc-0.3.0.9.tar.gz 572112 BLAKE2B df1ff046f4356f5feebf3551b3be9807b3bfca6ef927805efeb2ff5133968f1bd0ae14923ec83309ad2b8dd50d674f4506b1f62adc53a78f6afccea7cb6da5fa SHA512 48341417e955f8ee4f6ea5e446e37907ed7b75858418c248504d93496b64147d67d7ba5e35ca9033a528982a7650d3013574f5e8686acc085f267e3d6a44b93f
+DIST citeproc-0.7.tar.gz 528208 BLAKE2B 9ad395c2c3ba7bc957554b37af1a514c3deb3247a55a41b35c88b25f25db474043d18de5909e67ac5723fbfb0a5ed8161a16eb851f59c5648cfa3b30149c46fe SHA512 e24675c0d9227bd6ff5f13788c251647df1e61a65a1b0fe94d80c0bf064bd3018285ace6397d0c5f2b5d6e4ee9b91de8b90e6e4251e9914fb8fcbf58ed3c4539
diff --git a/dev-haskell/citeproc/citeproc-0.7.ebuild b/dev-haskell/citeproc/citeproc-0.7.ebuild
new file mode 100644
index 000000000000..9e98a83ddf64
--- /dev/null
+++ b/dev-haskell/citeproc/citeproc-0.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.1.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generates citations and bibliography from CSL styles"
+HOMEPAGE="https://hackage.haskell.org/package/citeproc"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="executable icu"
+
+# Many tests for this package are known to fail and this is acceptable for
+# upstream:
+# <https://github.com/jgm/citeproc#known-bugs-and-limitations>
+# The author seems to know which tests are expected to fail, but I
+# can't find documentation for exactly which ones.
+RESTRICT="test"
+
+RDEPEND="dev-haskell/aeson:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ >=dev-haskell/base-compat-0.10:=[profile?]
+ >=dev-haskell/case-insensitive-1.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ dev-haskell/file-embed:=[profile?]
+ >=dev-haskell/pandoc-types-1.22:=[profile?] <dev-haskell/pandoc-types-1.23:=[profile?]
+ dev-haskell/safe:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ >=dev-haskell/unicode-collation-0.1.3:=[profile?] <dev-haskell/unicode-collation-0.2:=[profile?]
+ dev-haskell/uniplate:=[profile?]
+ dev-haskell/vector:=[profile?]
+ dev-haskell/xml-conduit:=[profile?]
+ >=dev-lang/ghc-8.6.5:=
+ executable? ( dev-haskell/aeson-pretty:=[profile?] )
+ icu? ( >=dev-haskell/text-icu-0.7.1.0:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.4.0.1
+ test? ( >=dev-haskell/diff-0.4
+ dev-haskell/timeit )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag executable executable) \
+ $(cabal_flag icu icu)
+}