summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-01-16 17:44:47 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-01-16 19:42:39 +0000
commit16f15b47a397161202409da5bb0cdaf66dedae7e (patch)
tree1bd72569ba633036be73a01ff50e37aecbd4d55e /dev-haskell/crypto-conduit/crypto-conduit-0.5.5-r1.ebuild
parentdev-haskell/cpphs: bump up to 1.19.3 (diff)
downloadgentoo-16f15b47a397161202409da5bb0cdaf66dedae7e.tar.gz
gentoo-16f15b47a397161202409da5bb0cdaf66dedae7e.tar.bz2
gentoo-16f15b47a397161202409da5bb0cdaf66dedae7e.zip
dev-haskell/crypto-conduit: allow cereal-0.5
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-haskell/crypto-conduit/crypto-conduit-0.5.5-r1.ebuild')
-rw-r--r--dev-haskell/crypto-conduit/crypto-conduit-0.5.5-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-haskell/crypto-conduit/crypto-conduit-0.5.5-r1.ebuild b/dev-haskell/crypto-conduit/crypto-conduit-0.5.5-r1.ebuild
new file mode 100644
index 000000000000..35a550b74a44
--- /dev/null
+++ b/dev-haskell/crypto-conduit/crypto-conduit-0.5.5-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+#hackport: flags: -old-crypto-api
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Conduit interface for cryptographic operations (from crypto-api)"
+HOMEPAGE="https://github.com/prowdsponsor/crypto-conduit"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+conduit11"
+
+RDEPEND=">=dev-haskell/cereal-0.3:=[profile?]
+ >=dev-haskell/conduit-1.0:=[profile?] <dev-haskell/conduit-1.3:=[profile?]
+ >=dev-haskell/crypto-api-0.9:=[profile?] <dev-haskell/crypto-api-0.14:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?] <dev-haskell/transformers-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ conduit11? ( >=dev-haskell/conduit-extra-1.1:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/crypto-api-0.13
+ >=dev-haskell/cryptocipher-0.4
+ >=dev-haskell/cryptohash-cryptoapi-0.1
+ >=dev-haskell/hspec-1.3
+ >=dev-haskell/skein-0.1 )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'cereal >= 0.3 && < 0.5' 'cereal >= 0.3'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag conduit11 conduit11) \
+ --flag=-old-crypto-api
+}