summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/cryptohash-cryptoapi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/cryptohash-cryptoapi')
-rw-r--r--dev-haskell/cryptohash-cryptoapi/Manifest2
-rw-r--r--dev-haskell/cryptohash-cryptoapi/cryptohash-cryptoapi-0.1.0.ebuild27
-rw-r--r--dev-haskell/cryptohash-cryptoapi/cryptohash-cryptoapi-0.1.3.ebuild29
-rw-r--r--dev-haskell/cryptohash-cryptoapi/metadata.xml11
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-haskell/cryptohash-cryptoapi/Manifest b/dev-haskell/cryptohash-cryptoapi/Manifest
new file mode 100644
index 000000000000..cad03acaadc1
--- /dev/null
+++ b/dev-haskell/cryptohash-cryptoapi/Manifest
@@ -0,0 +1,2 @@
+DIST cryptohash-cryptoapi-0.1.0.tar.gz 2731 SHA256 7dca3a346747e1ba531bcd5824f3d8d630c137421049f55b38b78ace5b136619 SHA512 2f07c2901d6f5be24e5c3d94da5c37822d9efde9cea040e2093b98041bccfab9b6145890c062aca26bd642755c45a8b5255a6a69ed5162f69b301cebdfef9e54 WHIRLPOOL 5d7e720bc558e41b7ac773e37ec1cce8a5e2c22d1375a69671e59a00fbf190b40da37a039fb12404c5a6992174be5db2d45ed44429c2576f51f364df883ecbf7
+DIST cryptohash-cryptoapi-0.1.3.tar.gz 2922 SHA256 56f080ba13b891b664bd986db17d6c1240adaea4792a14c173146929c61d4572 SHA512 c33af37d4d1d8f3b13ad1ed93db4ec138ea3bef315006ee8117ccacb5c36e2afeb92ae903d46de537f0fbea2a262c5c487eb32d3e1d7099de27b53cc4f17889a WHIRLPOOL d3c21859f9c2fb376440022657d2d44541339933c12c294d12288fc63b8de46f8a57ffbfec84288011cdc901429ad6e6089adb0db13cb15ec96f972871778e0e
diff --git a/dev-haskell/cryptohash-cryptoapi/cryptohash-cryptoapi-0.1.0.ebuild b/dev-haskell/cryptohash-cryptoapi/cryptohash-cryptoapi-0.1.0.ebuild
new file mode 100644
index 000000000000..46b86bb585d8
--- /dev/null
+++ b/dev-haskell/cryptohash-cryptoapi/cryptohash-cryptoapi-0.1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Crypto-api interfaces for cryptohash"
+HOMEPAGE="http://github.com/vincenthz/hs-cryptohash-cryptoapi"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cereal-0.2:=[profile?]
+ >=dev-haskell/crypto-api-0.5:=[profile?]
+ >=dev-haskell/cryptohash-0.8.0:=[profile?]
+ >=dev-haskell/tagged-0.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/cryptohash-cryptoapi/cryptohash-cryptoapi-0.1.3.ebuild b/dev-haskell/cryptohash-cryptoapi/cryptohash-cryptoapi-0.1.3.ebuild
new file mode 100644
index 000000000000..3f444f315738
--- /dev/null
+++ b/dev-haskell/cryptohash-cryptoapi/cryptohash-cryptoapi-0.1.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Crypto-api interfaces for cryptohash"
+HOMEPAGE="http://github.com/vincenthz/hs-cryptohash-cryptoapi"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cereal-0.2:=[profile?]
+ >=dev-haskell/crypto-api-0.11:=[profile?]
+ >=dev-haskell/cryptohash-0.8.0:=[profile?]
+ >=dev-haskell/tagged-0.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
diff --git a/dev-haskell/cryptohash-cryptoapi/metadata.xml b/dev-haskell/cryptohash-cryptoapi/metadata.xml
new file mode 100644
index 000000000000..030483a1ecec
--- /dev/null
+++ b/dev-haskell/cryptohash-cryptoapi/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Crypto-api interfaces for cryptohash
+ </longdescription>
+ <upstream>
+ <remote-id type="github">vincenthz/hs-cryptohash-cryptoapi</remote-id>
+ </upstream>
+</pkgmetadata>