summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/css-text
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/css-text')
-rw-r--r--dev-haskell/css-text/Manifest2
-rw-r--r--dev-haskell/css-text/css-text-0.1.1.ebuild29
-rw-r--r--dev-haskell/css-text/css-text-0.1.2.1.ebuild29
-rw-r--r--dev-haskell/css-text/metadata.xml8
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-haskell/css-text/Manifest b/dev-haskell/css-text/Manifest
new file mode 100644
index 000000000000..16aa37d21ca9
--- /dev/null
+++ b/dev-haskell/css-text/Manifest
@@ -0,0 +1,2 @@
+DIST css-text-0.1.1.tar.gz 3139 SHA256 1ed480f350d0107e3ba95c33ab94ea4efd1956443cc7cc0f3f28616733026b83 SHA512 6a62eb4c9919ddc2b8143422fc4af8fcc54fec151d88b46ee34467c94a630b47773a6b4a24c634b44b7551e70b82ddc385345f85ebf2c5fb440ea06a96bee4a6 WHIRLPOOL bb727f9ad50abcbb563f9232766dbcb3143234379b8ce5c68132004559ff642c444fa24fe39db6f9ae46776f7d452507c41cc90bccd86d4f8f69b962bba886ca
+DIST css-text-0.1.2.1.tar.gz 3947 SHA256 dc0291da7ec756e4dda9dfadef303c78750eca63d07a5ad21dc4a3079cb021f6 SHA512 837b5e45ea87e4656a1a33b9a1ab098c03fa90a150ca6626dd4eaa75b4d35332703d2de6182d61dc1a144402366c6e74c3a85b60ff864aa080f8c8ef7b670bbc WHIRLPOOL f97587902a46a06aa608d58eaa9c761a06a5f153a879bae769989c086d201537c70c602c2f2471f6512492742a18c149e5b2d4aedb775186522e0207f773d97f
diff --git a/dev-haskell/css-text/css-text-0.1.1.ebuild b/dev-haskell/css-text/css-text-0.1.1.ebuild
new file mode 100644
index 000000000000..8062b13f1938
--- /dev/null
+++ b/dev-haskell/css-text/css-text-0.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="CSS parser and renderer"
+HOMEPAGE="http://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-0.6.1
+ >=dev-haskell/hunit-1.2
+ dev-haskell/quickcheck
+ )"
diff --git a/dev-haskell/css-text/css-text-0.1.2.1.ebuild b/dev-haskell/css-text/css-text-0.1.2.1.ebuild
new file mode 100644
index 000000000000..df04909a0ece
--- /dev/null
+++ b/dev-haskell/css-text/css-text-0.1.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="CSS parser and renderer"
+HOMEPAGE="http://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/attoparsec-0.10.2.0:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/quickcheck )
+"
diff --git a/dev-haskell/css-text/metadata.xml b/dev-haskell/css-text/metadata.xml
new file mode 100644
index 000000000000..01beb4039ac3
--- /dev/null
+++ b/dev-haskell/css-text/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ CSS parser and renderer.
+ </longdescription>
+</pkgmetadata>