summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/dataenc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/dataenc')
-rw-r--r--dev-haskell/dataenc/Manifest2
-rw-r--r--dev-haskell/dataenc/dataenc-0.14.0.5-r1.ebuild44
-rw-r--r--dev-haskell/dataenc/dataenc-0.14.0.5.ebuild34
-rw-r--r--dev-haskell/dataenc/dataenc-0.14.0.7.ebuild42
-rw-r--r--dev-haskell/dataenc/metadata.xml10
5 files changed, 132 insertions, 0 deletions
diff --git a/dev-haskell/dataenc/Manifest b/dev-haskell/dataenc/Manifest
new file mode 100644
index 000000000000..3db41ace4bb0
--- /dev/null
+++ b/dev-haskell/dataenc/Manifest
@@ -0,0 +1,2 @@
+DIST dataenc-0.14.0.5.tar.gz 12902 SHA256 1cb1aeb20b641149a1be9a8c18fa020dbf73441c89e78135ea272baf1696ea8d SHA512 b73e5060a3b9c00fbcdadb6dd8ca890c4a6f8ef862822e7d71bde1c0a99de1199cfa384cd8c219f41218f8eef4e9017ecc2c1c186516d7a809aadb599530bf88 WHIRLPOOL 403ba66caf2995f248d77baf66a6e6990216bdd517175df944157f9e43dfd0ab8787a2ad3d63e8164fd897130f40cc1433d3210c4768c60b57bd16ceb0cb543e
+DIST dataenc-0.14.0.7.tar.gz 12813 SHA256 f9d370a1ac1b9cd3c66abd13ad351270d020a21fcd774f49dae6cfa9f8a98ff3 SHA512 82f34ad51b64b66726e45c0c2ef52c9c2be201f42c5718763158a13eb2e8f82cb0298c1580dd52788e8d7b3f1eb0e7ade4e6e69f7ba4b2f8804eb2178e719e20 WHIRLPOOL 88e43031803c740f3f362560099e3febea05cf7a53fa68333161a3d893a36db47ce1e30c5e1c01e654431aaf1177971484ca6943f817657a4b42d42d204fdaef
diff --git a/dev-haskell/dataenc/dataenc-0.14.0.5-r1.ebuild b/dev-haskell/dataenc/dataenc-0.14.0.5-r1.ebuild
new file mode 100644
index 000000000000..46caeffbfef2
--- /dev/null
+++ b/dev-haskell/dataenc/dataenc-0.14.0.5-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Data encoding library"
+HOMEPAGE="http://www.haskell.org/haskellwiki/Library/Data_encoding"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND=">=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+ test? ( dev-haskell/hunit:=[profile?]
+ >=dev-haskell/quickcheck-2.5:=[profile?] <dev-haskell/quickcheck-2.7:=[profile?]
+ dev-haskell/test-framework:=[profile?]
+ dev-haskell/test-framework-hunit:=[profile?]
+ dev-haskell/test-framework-quickcheck2:=[profile?]
+ dev-haskell/test-framework-th:=[profile?] )
+"
+
+src_prepare() {
+ # allow ghc-7.7.2013+
+ cabal_chdeps \
+ 'array >= 0.1.0 && < 0.5' 'array >= 0.1.0 && < 0.6' \
+ 'base >= 3.0.0 && < 4.7' 'base >= 3' \
+ 'QuickCheck ==2.5.*' 'QuickCheck >=2.5 && <2.7'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test tests)
+}
diff --git a/dev-haskell/dataenc/dataenc-0.14.0.5.ebuild b/dev-haskell/dataenc/dataenc-0.14.0.5.ebuild
new file mode 100644
index 000000000000..4c6d7e8bddf8
--- /dev/null
+++ b/dev-haskell/dataenc/dataenc-0.14.0.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.1.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Data encoding library"
+HOMEPAGE="http://www.haskell.org/haskellwiki/Library/Data_encoding"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-fbsd ~ppc-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ cabal_chdeps \
+ 'array >= 0.1.0 && < 0.5' 'array >= 0.1.0 && < 0.6' \
+ 'base >= 3.0.0 && < 4.7' 'base >= 3.0.0'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-tests
+}
diff --git a/dev-haskell/dataenc/dataenc-0.14.0.7.ebuild b/dev-haskell/dataenc/dataenc-0.14.0.7.ebuild
new file mode 100644
index 000000000000..e78409bfbab5
--- /dev/null
+++ b/dev-haskell/dataenc/dataenc-0.14.0.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Data encoding library"
+HOMEPAGE="http://www.haskell.org/haskellwiki/Library/Data_encoding"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+ test? ( dev-haskell/hunit:=[profile?]
+ >=dev-haskell/quickcheck-2.5:2=[profile?]
+ dev-haskell/test-framework:=[profile?]
+ dev-haskell/test-framework-hunit:=[profile?]
+ dev-haskell/test-framework-quickcheck2:=[profile?]
+ dev-haskell/test-framework-th:=[profile?] )
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'base >= 3.0.0 && < 4.8' 'base >= 3.0.0' \
+ 'QuickCheck ==2.5.*' 'QuickCheck >=2.5'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test tests)
+}
diff --git a/dev-haskell/dataenc/metadata.xml b/dev-haskell/dataenc/metadata.xml
new file mode 100644
index 000000000000..7b979a0b1c25
--- /dev/null
+++ b/dev-haskell/dataenc/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Data encoding library currently providing Base16, Base32,
+ Base32Hex, Base64, Base64Url, Base85, Python string escaping,
+ Quoted-Printable, URL encoding, uuencode, xxencode, and yEncoding.
+ </longdescription>
+</pkgmetadata>