summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:07:06 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:09:29 +0100
commit39b65c2ed683f499214bac68fbe3ad396f8375ef (patch)
tree72747297394043dde68298ee7b320da10d4d6e10 /dev-haskell/doctest
parentdev-haskell/digest: add 0.0.1.3 (diff)
downloadgentoo-39b65c2ed683f499214bac68fbe3ad396f8375ef.tar.gz
gentoo-39b65c2ed683f499214bac68fbe3ad396f8375ef.tar.bz2
gentoo-39b65c2ed683f499214bac68fbe3ad396f8375ef.zip
dev-haskell/doctest: add 0.22.0
Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-haskell/doctest')
-rw-r--r--dev-haskell/doctest/Manifest1
-rw-r--r--dev-haskell/doctest/doctest-0.22.0.ebuild35
-rw-r--r--dev-haskell/doctest/metadata.xml11
3 files changed, 38 insertions, 9 deletions
diff --git a/dev-haskell/doctest/Manifest b/dev-haskell/doctest/Manifest
index 0acb39397be6..a99680e4fb23 100644
--- a/dev-haskell/doctest/Manifest
+++ b/dev-haskell/doctest/Manifest
@@ -1,2 +1,3 @@
DIST doctest-0.20.0.cabal 7121 BLAKE2B c9f87ca2f1a2250d042004ece7d6957683f487e2e87dca74e564792839019ce017ebdc19afa3742163cc1006177524ef130bc4ec701c3ac49e5a5918880af102 SHA512 08a3fcb4572b6c07266ae93505bc4a5ca0b52b03f1268dffcac291c5603babb9072503c7103a6b1f591235d26a52cdc66b86b2932f56b52d2beb06595510469a
DIST doctest-0.20.0.tar.gz 43796 BLAKE2B 7fe8b54ea9be6983cc3ce8d4c340528df533e48eafcd4c36d1cc38813b1b17469f4702064205a05e356e41d3dcefa3ba8ad556596851970edf639a5e50104d4d SHA512 037866d709fdd371941132aea31d15c65cbfcad7832cec4fa98ed580b939930cc2ef87eb77e8bdbf77bee40088b673afe66d9021d6e227416ede25159f8d93fa
+DIST doctest-0.22.0.tar.gz 45053 BLAKE2B c0f04a2d0b00790e1057cefdab4953e58b651551f3d03b4b211b9901f43f4b7dc4cc3bb51fcc01f96ef28d4a64fe84a2351a2f5123a6c0ce1380027b71f3dbdf SHA512 9da37402421243367ca307517c63abe93e93cdd10564c56d510e6a43345b4934a52c3201d0bfb3a2459d7c000d0ff5776a0cbd8e5db67f7e3a87bbac0172cd14
diff --git a/dev-haskell/doctest/doctest-0.22.0.ebuild b/dev-haskell/doctest/doctest-0.22.0.ebuild
new file mode 100644
index 000000000000..dc7c9f3630e0
--- /dev/null
+++ b/dev-haskell/doctest/doctest-0.22.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Test interactive Haskell examples"
+HOMEPAGE="https://github.com/sol/doctest#readme"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND=">=dev-haskell/base-compat-0.7.0:=[profile?]
+ >=dev-haskell/code-page-0.1:=[profile?]
+ >=dev-haskell/ghc-paths-0.1.0.9:=[profile?]
+ >=dev-haskell/syb-0.3:=[profile?]
+ >=dev-lang/ghc-8.0:=[profile?] <dev-lang/ghc-9.7:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+ test? ( >=dev-haskell/hspec-2.3.0
+ >=dev-haskell/hspec-core-2.3.0
+ dev-haskell/hunit
+ dev-haskell/mockery
+ >=dev-haskell/quickcheck-2.13.1
+ dev-haskell/setenv
+ >=dev-haskell/silently-1.2.4
+ >=dev-haskell/stringbuilder-0.4 )
+"
diff --git a/dev-haskell/doctest/metadata.xml b/dev-haskell/doctest/metadata.xml
index a51c87a6949b..eba755763568 100644
--- a/dev-haskell/doctest/metadata.xml
+++ b/dev-haskell/doctest/metadata.xml
@@ -5,15 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
- The doctest program checks examples in source code comments.
- It is modeled after doctest for Python
- (&lt;http://docs.python.org/library/doctest.html&gt;).
-
- Documentation is at
- &lt;https://github.com/sol/doctest-haskell#readme&gt;.
- </longdescription>
<upstream>
- <remote-id type="github">sol/doctest-haskell#readme</remote-id>
+ <remote-id type="hackage">doctest</remote-id>
+ <remote-id type="github">sol/doctest</remote-id>
</upstream>
</pkgmetadata>