summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-03-14 09:56:33 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-03-15 22:32:51 +0000
commite4d79c149e867ad4e3deff96032c6a14cca368cd (patch)
treed18bfb00ed869e8da26d7969c16a357b330d230b /dev-haskell/haddock-api/haddock-api-2.24.0.ebuild
parentdev-haskell/haddock-library: bump up to 1.9.0 (diff)
downloadgentoo-e4d79c149e867ad4e3deff96032c6a14cca368cd.tar.gz
gentoo-e4d79c149e867ad4e3deff96032c6a14cca368cd.tar.bz2
gentoo-e4d79c149e867ad4e3deff96032c6a14cca368cd.zip
dev-haskell/haddock-api: bump up to 2.24.0
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-haskell/haddock-api/haddock-api-2.24.0.ebuild')
-rw-r--r--dev-haskell/haddock-api/haddock-api-2.24.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/haddock-api/haddock-api-2.24.0.ebuild b/dev-haskell/haddock-api/haddock-api-2.24.0.ebuild
new file mode 100644
index 000000000000..d17fc17abb38
--- /dev/null
+++ b/dev-haskell/haddock-api/haddock-api-2.24.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CABAL_FEATURES="lib hoogle hscolour profile test-suite" # haddock
+inherit haskell-cabal
+
+DESCRIPTION="A documentation-generation tool for Haskell libraries"
+HOMEPAGE="https://www.haskell.org/haddock/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# keep in sync with ghc-8.10
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-haskell/ghc-paths-0.1.0.9:=[profile?] <dev-haskell/ghc-paths-0.2:=[profile?]
+ >=dev-haskell/haddock-library-1.9.0:=[profile?] <dev-haskell/haddock-library-1.10:=[profile?]
+ >=dev-haskell/xhtml-3000.2.2:=[profile?] <dev-haskell/xhtml-3000.3:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.0.0.0
+ test? ( >=dev-haskell/ghc-paths-0.1.0.12 <dev-haskell/ghc-paths-0.2
+ >=dev-haskell/hspec-2.4.4 <dev-haskell/hspec-2.8
+ >=dev-haskell/quickcheck-2.11
+ )
+"
+
+PATCHES=("${FILESDIR}"/${P}-ghc-8.10.2.patch )
+
+src_prepare () {
+ default
+
+ cabal_chdeps \
+ 'QuickCheck >= 2.11 && < 2.14' 'QuickCheck >= 2.11'
+}