summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/hastache
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/hastache')
-rw-r--r--dev-haskell/hastache/Manifest3
-rw-r--r--dev-haskell/hastache/hastache-0.5.1.ebuild32
-rw-r--r--dev-haskell/hastache/hastache-0.6.0.ebuild33
-rw-r--r--dev-haskell/hastache/hastache-0.6.1.ebuild34
-rw-r--r--dev-haskell/hastache/metadata.xml13
5 files changed, 115 insertions, 0 deletions
diff --git a/dev-haskell/hastache/Manifest b/dev-haskell/hastache/Manifest
new file mode 100644
index 000000000000..7abb2c222392
--- /dev/null
+++ b/dev-haskell/hastache/Manifest
@@ -0,0 +1,3 @@
+DIST hastache-0.5.1.tar.gz 12674 SHA256 c3f26caccaa67e3eb482b3c90c0f4817ae808001782a2459af0a06f6653d9516 SHA512 f7fe130ff047332d0db58b831f412ec398c8854f5401ff5de16493f503171e8735708c165bc090220f8db446a44389ec0715e6b4900994759093ff3e69e7a86a WHIRLPOOL fdbf5d8d685bbabca1427adaac842c9ed82a1ebf4a2e70078072b221d35d9be711885f068a97e7458494c50177889f92827f4ea4697e9a60f252b48cdd0a61a3
+DIST hastache-0.6.0.tar.gz 13195 SHA256 b033a0dd3a38e0ef0772562bb1d5ed8f535c2fa6955633875ae520a6614dc0fc SHA512 e6c4630ad278f70cf382f8b7a06bc535868b9000bd114d2b99856324703a78825bbd935a2693262a9c3b5bfc67fbe7f45edf9d56c973deaca1355ea708f965b7 WHIRLPOOL a9fdae1a7fd16f50f239728921fb185ebf980f20149b0830f84713e37b279c6acf13cf91dde866d6150b9ce763b5c0c95c7e80ed4b6f3c513ef17983aa060459
+DIST hastache-0.6.1.tar.gz 16452 SHA256 8c8f89669d6125201d7163385ea9055ab8027a69d1513259f8fbdd53c244b464 SHA512 3f7f7d0b97e88aca474b818c0e7b48187bfade855b6117dce50ed3e64b557586b1827272d46438a7e36990fb932d6503c982fa4fc6b2dbb33b463b14d39436b4 WHIRLPOOL cb04da4c92314c82e846b2f05a2deaf9910c06814e17d6ba39b61b0ee52ff42c0acf5b0966b75709580e44e3ad271632d7bd36a8f8ebc88879800cde17d228f5
diff --git a/dev-haskell/hastache/hastache-0.5.1.ebuild b/dev-haskell/hastache/hastache-0.5.1.ebuild
new file mode 100644
index 000000000000..1e1ab8898358
--- /dev/null
+++ b/dev-haskell/hastache/hastache-0.5.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell implementation of Mustache templates"
+HOMEPAGE="http://github.com/lymar/hastache"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/blaze-builder:=[profile?]
+ dev-haskell/ieee754:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ )"
diff --git a/dev-haskell/hastache/hastache-0.6.0.ebuild b/dev-haskell/hastache/hastache-0.6.0.ebuild
new file mode 100644
index 000000000000..cf2fdac2c4e5
--- /dev/null
+++ b/dev-haskell/hastache/hastache-0.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell implementation of Mustache templates"
+HOMEPAGE="http://github.com/lymar/hastache"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/blaze-builder:=[profile?]
+ dev-haskell/ieee754:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit )
+"
diff --git a/dev-haskell/hastache/hastache-0.6.1.ebuild b/dev-haskell/hastache/hastache-0.6.1.ebuild
new file mode 100644
index 000000000000..2d03b03ce857
--- /dev/null
+++ b/dev-haskell/hastache/hastache-0.6.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Haskell implementation of Mustache templates"
+HOMEPAGE="http://github.com/lymar/hastache"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RESTRICT=test # fails to build with ghc-7.10
+
+RDEPEND="dev-haskell/blaze-builder:=[profile?]
+ dev-haskell/ieee754:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/transformers:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit )
+"
diff --git a/dev-haskell/hastache/metadata.xml b/dev-haskell/hastache/metadata.xml
new file mode 100644
index 000000000000..c04154701a59
--- /dev/null
+++ b/dev-haskell/hastache/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ Haskell implementation of Mustache templates (&lt;http://mustache.github.com/&gt;).
+
+ See homepage for examples of usage: &lt;http://github.com/lymar/hastache&gt;
+ </longdescription>
+ <upstream>
+ <remote-id type="github">lymar/hastache</remote-id>
+ </upstream>
+</pkgmetadata>